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· From Windows, double-click on the Microsoft Excel icon to start Excel.
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Note that as you move the mouse around the spreadsheet, the mouse pointer changes.
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To move the highlighted cell, click on a cell.

· If the cursor is not already in cell A1 put it there.

· Type a number into cell A1.

As soon as you type a number (without entering it (see below), notice that a tick and a cross appear across the top as in the diagram below.
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At the moment because we haven’t ENTERED the number we are in limbo.* The hairline cursor is still in the cell at the end of the number we are entering. We need to enter this number. 
* Sometimes, when we are trying for example to use one of the toolbar commands nothing seems to work. It could be that you were half way through entering the data into the cell ie we had yet to do one of these
To enter this number (or characters) either 

· Press the Enter key on the keyboard. .

· Click on the green tick (recommended).

· Click anywhere else with the cursor (this can sometimes be a bit dangerous).

· Press any of the cursor arrow keys.

Editing

If you wish to delete the contents of a cell, simply click on the cell and then press the delete key (not the Backspace delete key!).

If you wish to completely change the contents of a cell, simply click on it and then type in the new entry.

If you wish to modify the contents of a cell, click on the cell whose contents you wish to modify and the click in the formula bar.
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Alternatively, to modify the contents of a cell:
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Remember that if you wish to cancel an operation, click on the red cross. 
To move a cell
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· If you hold down the control key throughout the operation above, the contents will be copied. Try it.
To select (or highlight) a set of cells,
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Note that the first cell still appears white! compared with the rest which are darkened. 
Don’t worry it is included!

· You could now for example change the font size or embolden the cells - or even delete all of these selected cells.

· To remove the highlighting click anywhere in the sheet.

Simple Formulas
To Add Two Numbers

· Type a couple of number as shown (any values )
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To subtract the two numbers.

· [image: image99.png]-




Change the plus sign to a minus.
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To divide the two numbers.

Use the / sign. i.e.  = a1/a2
To multiply the two numbers.

Use the * sign. i.e.  = a1 * a2  
( * is Shift 8 )
To raise to a power
Use the ^ sign (The caret which isShift 6)    eg   = 2 ^ 3.  (gives 8 )
Quick method of entering a formula

Say for example, we wished to add the two numbers below.
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· Type a plus sign ( + )
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· Finally click the green tick.

Series

· Type 1 and 2 in the cells as shown.
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· Click anywhere to remove the highlighting.

 (Pressing the escape key also removes the highlighting.)

· Repeat the procedure for a 1 entered into a cell as shown below.
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This time we get a series of 1's.
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· Click to remove the highlighting.
· Hold down the Ctrl-key and repeat the procedure above.
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Months and Days:

· Type jan and drag down.
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jan, feb,… is an inbuilt series. mon, tue, wed,… is another.
(You can even make your own! File, Options, Advanced, and then click the Edit Custom Lists… button (towards the bottom.)
Formulas
· Type some 2-digit number (any numbers) in the worksheet as below.
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To add up a column of numbers
· Place the cursor in cell A4 as above.

Choose the Home Tab on the ribbon.

In the Editing Group click AutoSum button (the “Sigma” button).
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The Sum formula should appear as below
 - asking us to confirm that we want to sum the cells A1 to A3.
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· Since we agree with this, click on the green tick.

The column total should now appear as below.
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· Repeat this procedure to add up the other 4 columns so that you should have a table similar to this:
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We are going to add up the first row.

· Click on the AutoSum button in the toolbar.

You should see the following formula appear:
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· Click the tick as before to add the row.
· Repeat for the second row. Your table should now appear as below.
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If you try to add up the 3rd row you should run into a problem.

The AutoSum, not unreasonably tries to add the two cells above.

To add this 3rd row, proceed as follows:
· Click on cell F3 and click the AutoSum button.
Note in the formula bar that it is trying to sum cells F1:F2. This is not what we want.
· Carefully click on cell A3 and drag across the row to E3 - (not F3!) - lasso them!

 so that the table looks like this:
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· Now click the green tick.
· Repeat the above procedure for the next row down

.
To Insert a New Row
· Place the cursor anywhere in the top row - say in cell A1 (as above).

We are going to make a new row above this row. (in order to put some headings at the top of the table.)

Choose the Home Tab on the ribbon. (Not the Insert Tab!)

Choose the Cells Group .

then click Insert , Insert Sheet Rows.
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A new row should now appear at the top. 
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Note that a new row was placed above the cell which was highlighted .

To Insert a New Column

We are going to insert a new column on the very left of the table.

· Place the cursor anywhere in the first column - say in cell A1.

· In the menu click on Insert.
· Click on Columns.
Choose the Home Tab on the ribbon. (Not the Insert Tab!)

Choose Cells Group.

[image: image128.png]Home  Inset  Pa

LI Calibri
23 Cony -
paste
"t Format painter | B £
Gipboars




then click Insert, Insert Sheet Columns.
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A new column should appear as follows.
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Note that a new column is always placed to the left of the highlighted cell.
· Type in the headings on the top and along the side as follows.

You may wish to simply type only week1 and drag the fill handle down.

Similarly with mon - drag it's fill handle across. 
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To Format the Headings
· Click on the little 1 immediately to the left of cell A1.
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This has the effect of selecting the whole row.





Note that the formatting that we applied to row 1 - bold and right justified - applies to the whole row.
If we were now to type anywhere in this row the same formatting would apply 
We will now select the first column and apply the same formatting.





To Change the Text Colour





· Change the colour of the text in the last column as well.



Copying Formulas

We are going to use another method to producing formulas so first we need to (almost) remove the ones we have.
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Copying Formulas continued





Let's say that we wished to multiply each of these numbers by 2.
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Let's say that we change our mind and we wish to multiply the three numbers by 3 instead of 2.
You might suggest that we re-type the first formula to = a1*3 and simply copy this down.
This is fine but what if formula needs to be changed in many places - all over the sheet.
We need a bit of forward planning.

First let's duplicate the situation whereby the three numbers are multiplied by 2.
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· Delete the three formulas and enter = a1*d1 for the first formula.
(To do this, you may prefer to edit the first formula by highlighting as shown below...
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…and then clicking on cell D1. )
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Absolute Reference
· Delete the bottom two formulas – see below:
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· If you now drag this formula down you will find that D1 (i.e. $D$1) remains fixed.
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Now - (the whole point of this exercise!), 
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Charts
We wish to produce a chart (graph) for our data as below.
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(If you don't have the table of data as above, make it now.)
· Place your cursor anywhere in the table then….


Your chart should appear as below.
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Note that if you now change a number in the table the chart will respond immediately!

· Try it.
Formatting Numbers

Percentage




















ie there are TWO ways of formatting as a percentage (and as currency etc).

To Change the Size of Rows and Columns













To Move a Column









Similarly we could move a row by highlighting it and dragging it.

Workbooks and Worksheets

Let's say that you typed in the following data and that we saved it as say Tax2004.





To Name a Sheet
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· Type  Income and then press Enter (or click elsewhere).
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A WorkBook can contain many WorkSheets.
A Workbook is often referred to as a Spreadsheet (singular!). This is for historical reasons. 

To Freeze Column and Row Titles
· Type some two digit numbers and headings thus and place the cursor as shown below.


Horizontal & Vertical division lines appear as below.

· Notice that if you scroll using the vertical and horizontal scroll bars, the numbers scroll beneath the headings.

This of course would be more useful with a very large worksheet.

· To unfreeze them, choose View, Freeze Panes, Unfreeze Panes
YouTube: ExcelAdvLesson2b: https://youtu.be/mPP_YN7Qlfs
Sorting Filtering Subtotals Goal Seek Linking  If
Sorting
· First make the following table.








         

For copying:
	Name
	Amount

	ed
	10

	jo
	20

	al
	10

	ed
	14

	jo
	18

	ed
	16
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· Place the cursor anywhere in the table that you wish to sort.



The table should appear sorted as follows.
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· (In order to sort in descending order, we would choose the Sort Descending button.)



· You may wish to undo the sort by clicking the Undo button.
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This is a simple sort. We may wish to also sort the second column as follows.
To Perform a more Complex Sort
We wish to sort by the first column and then the second column.
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· Place the cursor anywhere in the table that you wish to sort as above.
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Filtering
· First make the following table:

    for copying:
	STORE
	DEPT
	SALES

	New York
	Food
	10000

	
	Clothing
	20000

	London
	
	3000

	
	
	12000
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· To restore all the data click on the filter drop arrow and choose (Select All).
· You could try filtering other data.
· To remove the filter altogether, choose the Filter button on the ribbon again. 
Subtotals


· First make the following table and place the cursor in it. 






The table becomes highlighted and the following dialogue box appears.



When the sub-totalled table appears,

note the little 1,2,3 on the left of the sub- totalled table.

· Click these to investigate their effect.

· To remove the subtotals, click on Data , Subtotals..., Remove All.
Goal Seek









The Goal Seek command will automatically change one of the values in a cell to reach a target value which is in another cell.
· Make a table which simply adds 6 plus 4.  Use AutoSum to add them.
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Let’s say that we set the total of the two numbers to be 9 instead of 10 and request Excel to adjust cell A2. (i.e. Excel would need to set cell A2 to 3.)

· Make sure that the cursor is in cell A3.

· In the  Data Tab, What-If Analysis on the ribbon. 

· Data Tools  group. 
The following dialogue box appears.
 [image: image56.png]




After a while you should see 3 appear in A2!
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(This is a very simple example. A more complex example might be where wanted to set the vat for week1 (in a previous exercise) to be say £40 by changing one of the values - say Monday’s.)
· Try it.

Quick Data Entry
· Type the two entries ed and jo as below and move the cursor to the cell beneath and then right click.


When the drop box appears, as below, choose an entry.


eg ed will be entered as below:

· To make an entry exactly the same as the one above, click Ctrl ‘. (The Ctrl key and the apostrophe key) Try it.

· In the cell beneath, type the letter j.
 jo will appear. To accept it, press Enter. If you wish to type something else, just keep typing.
· To turn this option on/off choose (Tools, Options…, choose the Edit tab and check Enable AutoComplete for cell values.

To Link Two Worksheets





Notice how the cell border changes:




· In the second worksheet select any cell and right-click.




Now change the value in the first sheet. The value in the second sheet should change automatically to the same value.

Note the “formula” which appears in the Formula Bar at the top. (We might well have typed this formula long-hand.) Note the exclamation mark which always follows a sheet name.



To Insert a New Worksheet







To Move a Worksheet



The IF Statement

· Type the formula

 = if(A1>A2,"bigger","smaller")

into cell C2 along with the two numbers 20 and 30 as shown.


= if(A1>A2,"bigger","smaller")


· Change the 40 to 20.
You should find that the 2nd alternative ("smaller") appears in cell C2.
The "alternatives" need not be text as in "bigger" and "smaller". 
They can be numbers – or cell references as shown here:


(In practice, cell C2 could indicate a change in commission for a salesperson if his/her sales went above 30.)

For If exercise see page 25 of Manual 3 (xlExtraToDay1And2FinalVer1.doc)

Excel Exercises:

http://www.abacustraining.biz/ExcelExercises.htm

	hrs
	40
	
	

	ot lim
	30
	
	

	
	
	rate
	tot

	ot hrs
	10
	12.5
	125

	ord hrs
	30
	10.5
	315

	
	
	
	

	
	
	total pay:
	440


YouTubes
------------------------------------------------------------------------------------------------------------------

Manual 1st Part
· YouTube ExcelBegLesson1a: https://youtu.be/HS7beDaFNzQ
Entering Data
Editing
Simple Formulas Quick method of entering a formula




Series Formulas To Insert a New Row To Insert a New Column
To Format Headings



Copying Formulas

· YouTube ExcelBegLesson1b: https://youtu.be/HXRh9pvobm8
Absolute Reference Charts Formatting Numbers


· YouTube: ExcelAdvLesson2b: https://youtu.be/mPP_YN7Qlfs
Sorting


0:28

Filtering
 

3:14




Subtotals

5:25

Link Worksheets
11:11


Goal Seek

 8:05




The IF Statement
23:49
Manual 2nd Part
· YouTube  ExcelAdvLesson2c https://youtu.be/Ptxg-urzBUc
Vlookup




 0:13 

PivotTables




 8:01 

Macros: (next manual)



11:52

· YouTube ExcelAdvLesson2d.avi https://youtu.be/OSd6h2SXcjM
Scenarios




0:19

Solver 





2:47

Conditional Formatting



6:20

Names (next manual)



8:23

----------------------------------------------------------------------------------------------------------
Manual 3rd Part
Names (next manual)



8:23
---------------------------------------------------------------------------------

(This is what Excel 2010 looks like)





You should see a box around a cell 


This is known as the selection but also referred to as the cursor position.








Take note that the there is no tick and cross here as yet.                �


These will appear when we type something in!











(This is what Excel 2003 looks like. A drop down menu instead of a Ribbon as above in Excel 2010.)





If you change your mind, click the cross.





When you click here in the formula bar with the mouse, the hairline cursor is placed in here. You can now use all of the usual word-processing techniques (blocking off etc.) if you wish.





Double-click in the cell. The hairline cursor will be placed in the cell. You can now use all of the usual word-processing techniques. You can also press the F2 key at the top of your keyboard to “enter the cell”.





If you wish to move the contents of the cell, place the mouse cursor on an edge of a cell whereby it will change into a 4-headed arrow (not the bottom right).








(Of course, we could still use the Edit, Cut and Edit Paste etc commands from the Menu bar and Toolbar.)





Drag the cell and drop it where you wish.





Click in the middle of the first cell. Hold the cursor steady.


Notice that the cursor becomes a largish "Swiss cross".








Drag down








Click into this cell and type =a1+a2 (It doesn't matter if A (Capital) is used instead of a.)


Formulas always start with an equal sign.





Click the tick to enter the formula.





Note that if you click on a cell which was calculated using a formula, the formula appears on the formula bar.





Replace a number with another. You will find that the total automatically re-adjusts.





It's probably easiest to highlight the + and simply type - .


Click the green tick.





First type an equal sign.





Now carefully click in the cell A1.Notice that A1 is automatically entered! into the formula here (and here.)





Click in A2. 


Notice that it is also automatically entered into the formula.





Highlight the 1 and 2.


(Click in the middle of the cell A1 (the "swiss cross" will appear ) and drag down one cell )





Grab the fill handle with the mouse and drag down a bit.





Nothing seems to have happened but - let go…





Hey Presto!, Excel continues the series.





Grab the fill handle and drag down.





Consecutive numbers appear.


(As in the first example.)





Place the cursor in cell F1.








Click on the B on the Home Tab of the Ribbon in the Font group.


(Not the B column heading!) in order to make the heading bold.





To right-justify these headings as well, click on the right-align button. 








Click on the A column heading. The whole column will be selected.





You may notice something a bit strange. Look at the depressed buttons.





Excel seems to be telling us that this column is already bold and right-aligned which it isn’t.


The reason for this is that Excel is picking up on the first cell A1, which is bold and right-aligned.


After many years of patience and perseverance we have discovered what to do.





Click these buttons to take it off and then click them again to put it on for the whole column.





Click on this drop-down arrow to select the palette.





Select row 5 by clicking here.





Choose a colour and then click anywhere in the sheet to remove the highlighting.





Choose a colour and then click anywhere in the sheet to remove the highlighting.





Similarly delete these two formulas.





For this exercise highlight these five formulas and then delete them by pressing the delete key.





Tip: To reveal all formulas in your sheet, press the Control key along with the “grave” key” (At the very top left of the keyboard but below the escape key.)





We should now have only two formulas in place as below. (You may wish to click on them and inspect them to remind yourself what they contain.).





Click on the fill-handle and drag across.


When you release the mouse button you will find that the formulas have been automatically copied across





Repeat for the column.





Drag the fill handle of the first cell down.





Check out each formula by clicking in the cell and inspecting its actual formula in the edit bar.





(If you have work that you wish to come back to you may wish to use new sheet by clicking on a new sheet at the bottom of the screen.





Type in any 3 numbers 





Type the formula =a1*2 into the cell B1and click the tick.





Copy the formula down by dragging this fill-handle





Carefully inspect each formula. The A1 has been incremented to give A2 and A3. Excel has been very wise.





Place this number 2 in another cell of its own say here.





Drag down the fill-handle but when you release it you're in for a bit of a surprise.





If you inspect each of the formulas you might think that Excel has been a bit too clever.





 It has quite rightly incremented the A1 to A2 and A3 but it has also incremented the D1 to D2 and D3.





 We want it to remain D1. We need a way of stopping it from incrementing D1to D2 etc.





Now click in cell B1 and then click in the edit bar.





Carefully insert a $ sign (shift 4 ) on either side of the D. 





Quick method: Press the F4 key to automatically insert dollar signs into your formula.





Change the 2 to a 3.





The instant that you enter the 3 the numbers are updated!





Exercise:





Using absolute reference, make formulas to calculate VAT @ 15%on your totals.





The value of VAT should be placed in say cell I2





Change the VAT to 17.5%.





(If 17.5% decides to turn into 18% you may need to Format the cell to 2 decimal places.)








Click Insert Tab on the ribbon. Choose Column from the Charts  Group..








�





To change the size/shape of the chart, drag these sizing handles.





To remove these handles click anywhere outside.





If these sizing handles don't appear, carefully click on the outside border of the chart. (The "inside" border will also have its own sizing handles if you click on its border.)





The sizing handles are necessary if we wish to delete the chart. (The appearance of these sizing handles show that the chart is selected. )








Click this little arrow to get the Format Cells dialog box as below.





Type .5 here and then on the Home Tab on the ribbon choose the Number  Group…





Make sure that Number is selected.





Choose Percentage and then click OK.





The cell will be formatted as percentage





The cell will be formatted as percentage





Type 25 to replace the 50.00%. Note that it is not necessary to type the percent sign.








In another cell type 50%. Check out the formatting. (Click Format, Cells…).  You should find that this cell has now taken on the percentage formatting.








If you carefully place the mouse in the gap between two rows, a double-headed arrow appears which you can drag down to increase the row width.





Similarly, we can drag to increase the column width.





Sometimes hashes appear when the number is too wide for the cell.








(To simulate this, type a 14 digit number and then choose


 Format, Cells…Number, Number.)





We could drag the cell but if you double-click on the crack between the cells, the cell width will adjust automatically to the number width.








Click on the top of the column to highlight the whole column.





Move the mouse cursor to the edge of the selected area until you get a 4-headed arrow and then click and drag it here.





Finally click anywhere to remove the highlighting from the column.





Excel of course puts on its extension .xlsx. (You may remember that the extension for a Word for Windows document was .docx.). Extensions enable us to distinguish files on our computer.


In Excel WorkBooks have the extension .xlsx.





To name or rename a sheet ouble-click on Sheet1. It becomes highlighted.





Click on the  View Tab on the ribbon and choose the Window group.





�





Place the cursor as shown below.


Choose Freeze Panes and then Freeze Panes.


(Excel 2007/2010 has two extra (rather unnecessary) choices : Freeze Top Row and Freeze First  Column.











Choose the Data Tab on the ribbon. 


Sort & Filter  Group.





�














Click this for a simple sort.





(Note that Jo has still got his 20!)





From the Ribbon, choose Data, Sort…








Note that Excel doesn’t select the first row on your table on the Spreadsheet– and correspondingly this checkbox is checked. It is clever enough to assume that the first row is a header.








Choose Add Level (not OK yet!)








Choose name.








Choose amount then click OK.








Note that the amounts for each individual person are also now sorted as well. (Al has still got his 10 etc.)








Choose name








Make sure that your cursor is in the “table” and on the Data tab choose Filter.








The drop arrows appear on the field names as below. 








It is probably best to uncheck (Select All) first choose say only the London Stores.








The data must be sorted on Store first.





(You might like to also put some data in column D for experiment. You will find that it becomes messed up!). This is a shortcoming of SubTotals.





In the Data Tab on the ribbon in the Outline group choose Subtotal.








Make sure that these options are chosen and click OK.








This is the cell we wish to set to 9.








Click here and type 9.








This is the cell that we wish Excel  to change for us. 


Type A2.  (You could instead click on the cell A2).








Click the OK button.











Click the OK button.











� EMBED PBrush  ���





Select Pick from List.





� EMBED PBrush  ���





� EMBED PBrush  ���





� EMBED PBrush  ���





Quick Method:


Type = (equal) on Sheet1


Select a value on Sheet2. 


Press Enter.





Type a number in a cell.


Click the right button and select Copy from the shortcut menu.





Select this cell.





Copy it using the copy button.








From the Ribbon Choose the Home Tab then the 


ClipBoard  group 





�

















� EMBED PBrush  ���





� EMBED PBrush  ���





Change to Sheet2.





Alternative method. From the “second” sheet type equal. Go to the “first” sheet and click on the cell containing the number. Click the tick.





Choose Paste Special.





� EMBED PBrush  ���





� EMBED PBrush  ���





Click Paste Link and click OK..





On the Home Tab on the ribbon. 


In the Cells  group. Choose Insert Sheet.





�

















� EMBED PBrush  ���





Or right-click in the sheet tabs at the bottom of the workbook and choose Insert and the a Worksheet and click OK.























A new worksheet appears.





� EMBED PBrush  ���





� EMBED PBrush  ���





Simply click on the sheet and drag it to the desired position.





� EMBED PBrush  ���





� EMBED PBrush  ���





If this is a true statement (which it is in this case since 40 is larger than 30) then the first "alternative" which is "bigger" is "selected" otherwise the second statement is selected


Rule: The first alternative is chosen if the statement is true. The second alternative is chosen if the statement is false.





� EMBED PBrush  ���





Shop assistants earn £12.50  per hr if they work over 30 hrs otherwise they get £10.50 for hrs under 30.


If they work 40 hrs how much do they get?


(ans £440 as shown here.)


If they work 20 hrs how much do they get? 


(ans £210)


The Excel formulas should handle all situations as above.


Hint Use two IF’s. Make one IF formula for the “ordinary” hrs and another IF just for the overtime hrs. 
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