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Templates

Templates contain fixed headings.

A template is used to create documents containing these fixed headings.

For example, we may have monthly expenditures as shown. 
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We wish to save this as a template.
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We now wish to make a spreadsheet based upon this template.
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A document opens:
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· Choose File, Save As…
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· Close the spreadsheet.

· Create another spreadsheet based upon out template by choosing File, New… once again.
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· Enter new figures and save it as February.xlsx.

Things to remember:
When making a template, save it as an .xltx (or xltm).

When using our template, choose File, New… and not File Open…

We would use File Open…if we wished to alter the actual template.
Scenario Manager







Scenario Manager enables you to “try out “a set of values and watch the effect they have on some value which has been calculated using a formula.

We can save one or more sets of these trial values under a name and then call them at will.

Look at the table below.

We are going to try a set of values which we will call best.
The value of Sales will be 20 and the value of Costs will be 2.

The other scenario will be called worst ; the value of Sales will be 8
and the value of Costs will be 1.

First the Sales will be 10 and the Costs 5 and in cell B3, type the formula  = B1-B2 in order to calculate the Profit.
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On the Ribbon choose the Data tab and then Scenario Manager.
The following dialogue box appears:
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· Click OK
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· Click OK
· Repeat the above to produce another scenario called worst using the values say 8 and 1. Finally , Click OK,

[image: image54.png]


To try each scenario:




The following scenario should appear:




· In the Scenario Manger dialogue box  choose the worst scenario

The following scenario should appear::




Pivot Tables








A Pivot table is an alternative way of viewing data in a table. It relies upon having repeated data in columns and using these repeated data to make row and column “headings”.
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First make the following table.

Data for pasting:
	Store
	Dept
	Sales

	New York
	Food
	10000

	New York
	Clothing
	20000

	London
	Food
	25000

	London
	Clothing
	25000
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We will make the following pivot table from the above table As well as re-arranging the data, a  Pivot Table produces subtotals as shown in the table below.
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We will now produce the above Pivot Table.

· Place the cursor anywhere in your list (a list is a table of data).

On the Ribbon choose the Insert tab and then the Tables group.

Choose Pivot Table, Pivot Table.
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The Pivot Table should finally appear as below:
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Solver










Solver is similar to Goal Seek but it allows us to change more than one cell to achieve say a certain total.

· Set-up the table of numbers as in the diagram below. Use AutoSum to add the 6 and the 4.

Let’s say that we wanted a total of 9 instead of 10 but this time we wanted Excel to adjust both numbers. We therefore need to stipulate how these two numbers are to be constrained. Let’s say that we simply wanted them to be equal.

(Excel would therefore need to provide the solution of 4.5 and 4 5.)
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On the Ribbon choose the Data tab and then the Analysis group. Choose Solver

The following dialogue box should appear.

[image: image70.png]2501
+

1 [N R
2 FE I N
3 40 240]____aa0]
4 150 El
2





[image: image71.png]120
130
140
150

C
20 i |

2307 330
20 30

0] 30
+

420
430
440
450



[image: image72.png]4 7 @

Wordart Signature Object

Tet

Header & Footer







· Select cells A1 and A2 by clicking on cell A1 and dragging to A2.
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We now need to set the constraint that A1 should be equal to A2.

· Click on the Add... button. 

The following dialogue box should appear.
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· Click on the OK button.

The Solver Parameters dialogue box should re-appear.
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You should get the following result:




· Click the OK button.

Conditional Formatting
· Take note where your cursor is:
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On the Ribbon, choose the Home tab and then the Styles group.
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· Now if we type a number greater than 10 its formatting will appear as:

· Whereas tying a number less than 10 will not:

VLookup YouTube: ExcelAdvLesson2c https://youtu.be/Ptxg-urzBUc 
0:13secs
Excel VLookup Macros PivotTables 

· Make the following table and type the formula 

=VLookup(40,A1:b4,2,False) into say cell D1.
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=vlookup(40,A1:b4,2,False)




Hlookup is used when we want to search down a column instead of across a row.

The 3rd number in the formula (the 2 in the above formula) will then be the number of the row to be searched.


The Meaning of the False in the Formula

For example try looking for 35 instead of 40 using VLookup.
An #NA message will result because an exact match could not be found as shown below.



What if we are happy to find a value corresponding to the value which is just below (in value) the one we are looking for?

We must do two things: (do this)

· 1. Sort the data. 

· 2. Change the False to True (or omit it – it’s the default)





Good YouTube :
https://exceljet.net/tips/how-to-use-vlookup-for-approximate-matches
Data Validation













Comments



· Type in the comment.


From now on, every time that we click in this cell the comment box will appear.

To make comments always appear choose from the menu File, Excel Options and then..



For this particular workbook we can choose :




To PRINT the comments (when we print the spreadsheet.):



To Set the Print Area

· First select (only) the area that we wish to print.





· Change to Print view. (File, Print)



To Remove the Print Area

Choose the Page Layout tab, Print Area, Clear Print Area.


Page Break Preview



Your data should appear in Page Break Preview along with maybe a dialog box telling you what to do.



To Return to Normal View:




To Insert a Page Break
Place the cursor beneath (or to the right of) where you wish the break to occur.



· To break the page vertically, place the cursor to the right of the required page break as below.


· To simultaneously break the page vertically and horizontally, place the cursor to the right and below.

To Remove a Page Break
· Place the cursor beneath the Page Break.



Header and Footer

A header is something which appears at the top of every page (perhaps the company name).

A footer is something which appears at the bottom of every page (perhaps the page number).

For the purpose of the exercise, make sure that you have more than one page and also name it (eg test.xlsx).

We wish to make a footer which will show the name (test.xlsx) of the document.

On the Ribbon choose the Insert tab and then the Text group.






If we now choose File, Print..


A little obscurely, if we wish to exit from this Header view we must….



Quite bizarrely if we want to modify the header then we must choose Insert again.
· Try it.

To Insert a Footer

As before choose Insert, Header & Footer
but now choose Go To Footer.

We can choose to put the name of the spreadsheet as a footer:




· Preview our spreadsheet .



Merge & Centre:









Experiment with the Wrap Text feature above.

To Apply a Border

· First select the cells around which we wish to place a border as below


On the Ribbon choose the Home tab and then the Font group










· Choose preview (File, Print) to view our border which should appear as below.


To Turn the Gridlines On and Off
There are two types : The ones visible on the spreadsheet  itself and the ones for printing.

Aternatively:

For permanence ie for future spreadsheets : For Excel 2010: Choose File.

(Excel 2007 Choose the Office button) and then Excel Options.




Use your own current spreadsheet instead if you wish.





Create these headings and change the name of the sheet to expenditure.





In Excel 2007 we have the “Office Button” instead of “File”.�


�





Excel 2010.





Choose File, Save As…








Note that the Templates folder is automatically chosen. Take care with this.  This can be a source of confusion.





Name it MonthlySales.





Choose Template(*.xltx)


 (or xltm if macro-enabled).





Note the name of our template at the top.





Close it.  File, Close.








Chose File, New. (NOT File, Open!)





Choose My templates.�





Double-click on our template.





Note the temporary default name of the document.





This is a document based upon our template.





Fill in some data for this month.








Ensure that you are saving it as an .xlsx.





 Give it a name and click Save..








This time you could choose My templates again or choose it from Recent templates.





A spreadsheet based upon our template opens. Note that it is a “tabula rasa”.





Click Add 





Click in here and type say best.





Click in here and then select the range B1:B 2 by dragging the range B1:B2 on the spreadsheet.





Type 20 in here.





Click in here and type 2.





Select the scenario best and click the Show button to change the values in the table.





Click OK.





Take care to choose Existing Worksheet.


Choose a location.





Check (tick) these.





If you take a look at the pivot table that we are trying to produce (see below), you will see that the


Dept should be in the Column Labels and


Sales in Values leaving


Store in Row Labels. Drag these accordingly.





Click here.





Click here





Type 9





If Solver is not available:�Click the Microsoft Office Button � INCLUDEPICTURE "ms-help://MS.EXCEL.12.1033/EXCEL/content/O12FileMenuButton_ZA10077102.gif" \* MERGEFORMATINET ���, click Excel Options, and then click the Add-ins category. �In the Manage box, click Excel Add-ins, and then click Go. �In the Add-ins available box, select the Solver Add-in check box, and then click OK. 





You should then see $A$1:$A$2 appear here.





Click here





$A$1 should then appear here.





Click in here.


Click on cell A2.


$A$2 should appear here.





Click on this drop arrow and then chose the = sign.





Click the Solve button.





Choose Conditional Formatting.





Highlight Cells Rules, Greater Than..





Choose say 10.





Choose a formatting and then click OK.





A1:B4 is the range we are searching 





40 is the number in the first column that we are searching for.





We wish to find the corresponding number in column number 2.


(Of course there may be more than 2 columns.)





The False in the formula indicates that we are looking for an exact match (see next page.)





� EMBED PBrush  ���





30 is smaller than 35 and hence 85 is returned.





 On the Ribbon choose the Data tab and then the Data Tools group and then Data Validation..





�




















Click the Error Alert tab and then type in the message that you wish to appear when invalid data is entered and then click OK...





Choose


 Whole number between 1 and 5.





� EMBED PBrush  ���





� EMBED PBrush  ���





Now when we enter data which doesn’t satisfy the criterion we will get the following message in a dialog box.





On the Ribbon choose the Review tab and then the Comments group and then New Comment.





�




















� EMBED PBrush  ���





Note the appearance of a little red triangle to indicate that the cell has a comment associated with it.





Make a choice from here.





Show all comments.





Click the little arrow and then choose Sheet, Comments, As Displayed on sheet, OK,





� EMBED PBrush  ���





On the Ribbon choose the Page Layout tab and then the Page Setup group.





�




















� EMBED PBrush  ���





Note the dotted boundary.





� EMBED PBrush  ���





Now only our selected numbers will be printed.





On the Ribbon Choose the View tab and then the Workbook Views group.





�





and then Page Break Preview.














� EMBED PBrush  ���





Take note.





From the View tab choose Normal from the Workbook Views tab.





From the Page Layout, Breaks choose Insert Page Break.





� EMBED PBrush  ���





� EMBED PBrush  ���





Page Layout tab, Beaks, Remove Page Break.


.


�




















Select Header/Footer…





Type in your header.





.. the header will appear on each page.





… choose View, Normal.





Choose Footer form the Header & Footer group and the choose our spreadsheet name.





The name of your file should appear at the bottom of each page. 





Select two cells. 





From the Alignment group on the Home tab choose Merge & Center (sic)





The cells are merged and centred. 





� EMBED PBrush  ���





Either choose from here or..





.. choose More Borders.





Choose Border.





First, choose the border line and its colour.





Then, choose the type of border and click OK.





� EMBED PBrush  ���





Choose the Page Layout tab on the Ribbon.





Check the View or Print boxes. Note the explanation.





Uncheck Show Gridlines.





Choose Advanced.





The gridlines  disappear.
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