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· From Windows, double-click on the Microsoft Excel icon to start Excel.

				
 (
You should see a box around a cell 
This is known as the selection but 
also 
referred to as the cursor position.
) (
Take
 note that the there is no tick 
and
 cross here 
as yet
.
         
 
      
These will appear when we type something in!
)













Note that as you move the mouse around the spreadsheet, the mouse pointer changes.

To move the highlighted cell, click on a cell.

· If the cursor is not already in cell A1 put it there.

· Type a number into cell A1.

As soon as you type a number (without entering it (see below), notice that a tick and a cross appear across the top as in the diagram below.
 (
(
This is what Excel 2003 looks like
. A 
drop down
 menu instead of a Ribbon as above in Excel 2010.)
)





 (
If you change your mind, click the cross
.
)






At the moment because we haven’t ENTERED the number we are in limbo.* The hairline cursor is still in the cell at the end of the number we are entering. We need to enter this number. 
* Sometimes, when we are trying for example to use one of the toolbar commands nothing seems to work. It could be that you were half way through entering the data into the cell ie we had yet to do one of these

To enter this number (or characters) either 

· Press the Enter key on the keyboard. .

· Click on the green tick (recommended).

· Click anywhere else with the cursor (this can sometimes be a bit dangerous).

· Press any of the cursor arrow keys.

Editing

If you wish to delete the contents of a cell, simply click on the cell and then press the delete key (not the Backspace delete key!).

If you wish to completely change the contents of a cell, simply click on it and then type in the new entry.

If you wish to modify the contents of a cell, click on the cell whose contents you wish to modify and the click in the formula bar.

 (
When you click here in the 
formula
 bar with the mouse, the hairline cursor is placed in here. You can now use 
all of
 the usual word-processing techniques (blocking off etc.) if you wish.
)

Alternatively, to modify the contents of a cell:








 (
Double-click in the cell
. The hairline cu
rsor will be placed in the cell
. You can now use 
all of
 the usual word-processing techniques.
 You can also press the F2 key at the top of your keyboard to “enter the cell”.
)







Remember that if you wish to cancel an operation, click on the red cross. 

To move a cell





 (
If you wish to 
move
 the contents of the cell, place the mouse cursor on an 
edge
 of a cell whereby it will change into a 
4-headed arrow (not the bottom right)
.
)





 (
(Of course, we could still use the Edit, Cut and Edit Paste 
etc
 commands from the Menu bar and Toolbar.)
)
 (
Drag the cell and drop it where you wish.
)






· If you hold down the control key throughout the operation above, the contents will be copied. Try it.


To select (or highlight) a set of cells,


 (
C
lick 
in the middle
 of the first cell. Hold the cursor steady.
Notice that the cursor becomes a largish "Swiss cross".
)


 (
Drag down
)


Note that the first cell still appears white! compared with the rest which are darkened. 
Don’t worry it is included!

· You could now for example change the font size or embolden the cells - or even delete all of these selected cells.

· To remove the highlighting click anywhere in the sheet.


Simple Formulas
To Add Two Numbers

· Type a couple of number as shown (any values )


 (
Click into this cell and type =a1+a2 (It doesn't matter if A (Capital) is used instead of a.)
Formulas always start with an equal sign.
)

 (
Click the tick to enter the formula
.
)



 (
Note that if you click on a 
cell
 which
 was calculated using a formula
, the formula appears on the
 
formula bar.
)




 (
Replace 
a
 number with another. You will find that the total automatically re-adjusts.
)


To subtract the two numbers.

·  (
It's probably easiest to 
highlight
 the + and simply type 
- .
Click the green tick.
)Change the plus sign to a minus.



To divide the two numbers.

Use the / sign. i.e.  = a1/a2

To multiply the two numbers.

Use the * sign. i.e.  = a1 * a2  	( * is Shift 8 )

To raise to a power

Use the ^ sign (The caret which isShift 6)    eg   = 2 ^ 3.  (gives 8 )
Quick method of entering a formula

Say for example, we wished to add the two numbers below.

 (
First type an equal sign.
)


 (
Now carefully click in the cell A
1.Notice
 t
hat A1 is automatically entered! into the formula here (and here.
)
)









· Type a plus sign ( + )

 (
Click in A2. 
Notice that it is also automatically entered into the formula
.
)


· Finally click the green tick.



Series

· Type 1 and 2 in the cells as shown.


 (
Highlight
 the 1 and 2.
(C
lick in the middle of the cell A1 (the "
swiss
 cross" will 
appear )
 and drag
 
down one cell )
) (
Grab the fill handle with the mouse and drag down a bit.
)

 (
Nothing seems to have happened but - let go…
)


 (
Hey 
Presto!,
 Excel continues the series
.
)


· Click anywhere to remove the highlighting.
 (Pressing the escape key also removes the highlighting.)



· Repeat the procedure for a 1 entered into a cell as shown below.


 (
Grab the fill handle and drag down.
)

This time we get a series of 1's.



· Click to remove the highlighting.

· Hold down the Ctrl-key and repeat the procedure above.


 (
Consecutive numbers appear.
(As in the first example.)
)

Months and Days:

· Type jan and drag down.


		

jan, feb,… is an inbuilt series. mon, tue, wed,… is another.

(You can even make your own! File, Options, Advanced, and then click the Edit Custom Lists… button (towards the bottom.)


Formulas

· Type some 2-digit number (any numbers) in the worksheet as below.



To add up a column of numbers

· Place the cursor in cell A4 as above.

Choose the Home Tab on the ribbon.
In the Editing Group click AutoSum button (the “Sigma” button).



The Sum formula should appear as below
 - asking us to confirm that we want to sum the cells A1 to A3.





· Since we agree with this, click on the green tick.

The column total should now appear as below.




· Repeat this procedure to add up the other 4 columns so that you should have a table similar to this:

 (
Place the cursor in cell 
F1
.
)


We are going to add up the first row.

· Click on the AutoSum button in the toolbar.

You should see the following formula appear:





· Click the tick as before to add the row.


· Repeat for the second row. Your table should now appear as below.




If you try to add up the 3rd row you should run into a problem.

The AutoSum, not unreasonably tries to add the two cells above.


To add this 3rd row, proceed as follows:

· Click on cell F3 and click the AutoSum button.

Note in the formula bar that it is trying to sum cells F1:F2. This is not what we want.

· Carefully click on cell A3 and drag across the row to E3 - (not F3!) - lasso them!
 so that the table looks like this:




· Now click the green tick.

· Repeat the above procedure for the next row down
.
To Insert a New Row

· Place the cursor anywhere in the top row - say in cell A1 (as above).

We are going to make a new row above this row. (in order to put some headings at the top of the table.)

Choose the Home Tab on the ribbon. (Not the Insert Tab!)
Choose the Cells Group .
then click Insert , Insert Sheet Rows.









A new row should now appear at the top. 




Note that a new row was placed above the cell which was highlighted .
To Insert a New Column

We are going to insert a new column on the very left of the table.

· Place the cursor anywhere in the first column - say in cell A1.

· In the menu click on Insert.

· Click on Columns.

Choose the Home Tab on the ribbon. (Not the Insert Tab!)
Choose Cells Group.
then click Insert, Insert Sheet Columns.









A new column should appear as follows.




Note that a new column is always placed to the left of the highlighted cell.

· Type in the headings on the top and along the side as follows.

You may wish to simply type only week1 and drag the fill handle down.

Similarly with mon - drag it's fill handle across. 





To Format the Headings

· Click on the little 1 immediately to the left of cell A1.




This has the effect of selecting the whole row.

 (
Click on the B on the Home Tab of the Ribbon in the Font group.
(Not the B column heading!
) 
in order to
 make the heading
 
bold.
)
























 (
To right-justify these headings as well, click on the right-align button. 
)



Note that the formatting that we applied to row 1 - bold and right justified - applies to the whole row.
If we were now to type anywhere in this row the same formatting would apply 

We will now select the first column and apply the same formatting.



 (
Click on the A column heading. The whole column 
will be
 selected.
)


















 (
You may notice something a bit strange. Look at the depressed buttons.
Excel seems to be telling us that this column is already bold and 
right-aligned
 which it isn’t.
The reason for this is that Excel is picking up on the first cell A1, which 
is
 bold and 
right-aligned
.
After many years of patience and perseverance we have discovered what to do.
Click these buttons to take it off and then click them again to put it on for the whole column.
)









To Change the Text Colour

 (
Click 
on this drop-down arrow
 to select the palette.
) (
Select row 5 by clicking here.
)


















 (
Choose a 
colour
 and then click anywhere in the sheet to remove the highlighting.
)


· Change the colour of the text in the last column as well.
 (
Choose a 
colour
 and then click anywhere in the sheet to remove the highlighting.
)
Copying Formulas

We are going to use another method to producing formulas so first we need to (almost) remove the ones we have.



 (
Similarly delete these two
 
formulas.
) (
For this exercise highlight
 these five formulas and then delete them by pressing the delete key.
)




 (
Tip: To reveal all formulas in your sheet, press the Control key along with the “grave” key” (At the very top left of the keyboard but below the escape key.)
) (
We should now have only two formulas in place
 as below
. 
(
You may wish to click on them and inspect them to remind yourself what they contain
.)
.
)


















 (
Click on the fill-handle and drag across.
When you release the mouse button you will find that the formulas have been automatically copied across
)




 (
Repeat for the column.
Drag the fill handle of the first cell down
.
)

 (
Check out each formula by clickin
g in the cell and inspecting it
s actual formula in the edit bar.
)

Copying Formulas continued

 (
(If you have work that you wish to come back to you may wish to 
use new 
sheet by clicking on a new sheet at the bottom of the 
screen.
)







 (
Type in any 3 numbers 
)



Let's say that we wished to multiply each of these numbers by 2.


 (
Type the formula =a1*2 into the cell B1and click the tick.
)

 (
Copy the formula down by dragging this fill-handle
)


 (
Careful
ly inspect each formula. The A1
 has been incremented to give A2 and A3. Excel has been very wise.
)



Let's say that we change our mind and we wish to multiply the three numbers by 3 instead of 2.

You might suggest that we re-type the first formula to = a1*3 and simply copy this down.

This is fine but what if formula needs to be changed in many places - all over the sheet.

We need a bit of forward planning.

First let's duplicate the situation whereby the three numbers are multiplied by 2.

 (
Place this number 2 in anothe
r cell of it
s own say here.
)






· Delete the three formulas and enter = a1*d1 for the first formula.

(To do this, you may prefer to edit the first formula by highlighting as shown below...




…and then clicking on cell D1.)




 (
Drag down the fill-handle but when you release 
it
 you're in for a bit of a surprise.
)



 (
If you inspect each of the 
formulas
 you might think that Excel has been a bit too clever.
 It has quite rightly incremented the A1 to A2 and 
A3
 but it has also incremented the D1 to D2 and D3.
 We want it to remain D1. We need a way of stopping it from incrementing D1
to D2 etc
.
)








[bookmark: AbsoluteRef]Absolute Reference

Delete the bottom two formulas – see below:

 (
Now c
lick in cell B1 and then click in the edit bar.
Carefully insert a $ sign (shift 
4 )
 on either side of the D. 
)




 (
Quick method
: Press the F4 key to automatically insert dollar signs into your formula.
)



· If you now drag this formula down you will find that D1 (i.e. $D$1) remains fixed.




Now - (the whole point of this exercise!), 
 (
Change the 2 to a 3.
)


 (
The instant that you ente
r the 3 the numbers are updated
!
)




 (
Exercise
:
Using absolute reference, make formulas to calculate VAT @ 15%on your totals.
The value of VAT should be placed in say cell 
I2
Change the VAT to 17.5%.
(If 17.5% decides to turn into 18% you may need to Format the cell to 2 decimal places.)
)



Charts

We wish to produce a chart (graph) for our data as below.




(If you don't have the table of data as above, make it now.)

· Place your cursor anywhere in the table then….

 (
Click Insert Tab on the ribbon. Choose Column from the 
Charts  Group..
)















Your chart should appear as below.



 (
To change the size/shape of the chart, drag these sizing handles.
To remove these 
handles
 click anywhere outside.
If these sizing handles don't appear, carefully click on the outside border of the chart. (The "i
nside" border will also have it
s own sizing handles
 if you click on it
s border.)
The sizing handles are necessary if
 we wish to delete the chart. (
The appearance of these sizing handles show that the chart is selected
. )
)












Note that if you now change a number in the table the chart will respond immediately!
· Try it.
[bookmark: Formatting]
Formatting Numbers

[bookmark: Charts]Percentage











 (
Click this li
t
tle arrow to get the Format Cells dialog box
 as below
.
) (
Type .5 here and then 
on the Home Tab on the ribbon choose the 
Number  Group
…
)






 (
Make sure that 
Number 
is selected.
)



 (
Choose 
Percentage
 and then click 
OK
.
)












 (
The cell will be formatted as percentage
) (
The cell will be formatted as percentage
)



 (
Type 25 to replace the 50.00%. Note that it is not necessary to type the percent sign.
)




 (
In another cell type 50%. 
Check out the formatting. (Click Format, Cells…).  You should find that this cell has now taken on the percentage formatting.
)







ie there are TWO ways of formatting as a percentage (and as currency etc).
To Change the Size of Rows and Columns


 (
If you carefully place the mouse in the gap between two rows, a double-headed arrow appears which you can drag down to increase the row width.
)










 (
Similarly, we can drag to increase the column width.
)





 (
Sometimes hashes appear when the number is too wide for the cell.
)



 (
(To 
simulate this
, type a 
14 digit
 number and then choose
 
F
ormat, C
e
lls…Number, Number.)
)




						
 (
We could drag the cell but if you double-click on the crack between the cells, the cell width will adjust automatically to the number width.
)
To Move a Column


 (
Click on the top of the column to highlight the whole column.
)













 (
Move the mouse cursor to the edge of 
the sele
cted area until you get a 4-headed arrow
 and then 
click and 
drag it here.
)










 (
Finally click anywhere to remove the highlighting from the column.
)






Similarly we could move a row by highlighting it and dragging it.



Workbooks and Worksheets

Let's say that you typed in the following data and that we saved it as say Tax2004.

 (
E
xcel of course puts on it
s extension .xls
x
. (You may remember that the extension for a Word for Windows document was .doc
x
.). Extensions enable us to distinguish files on our computer.
In Excel 
WorkBooks
 have the extension .xls
x
.
)





















To Name a Sheet

 (
To name or rename a sheet 
ouble
-click on Sheet1. It becomes highlighted.
)






· Type  Income and then press Enter (or click elsewhere).





A WorkBook can contain many WorkSheets.

A Workbook is often referred to as a Spreadsheet (singular!). This is for historical reasons. 
[bookmark: Freeze]
To Freeze Column and Row Titles

· Type some two digit numbers and headings thus and place the cursor as shown below.








 (
Click on the View Tab on the ribbon and in the 
Window
 group choose Freeze Pains.
)

(The Other choices are Freeze Top Row and Freeze First  Column.)


Horizontal & Vertical division lines appear as below.









· Notice that if you scroll using the vertical and horizontal scroll bars, the data scrolla beneath the headings.

This of course would be more useful with a very large worksheet.

· To unfreeze them, choose View, Freeze Panes, Unfreeze Panes


YouTube: ExcelAdvLesson2b: https://youtu.be/mPP_YN7Qlfs
Sorting Filtering Subtotals Goal Seek Linking  If

[bookmark: Sort]
Sorting
	
· First make the following table.
							         		ie
	Name
	Amount

	ed
	10

	jo
	20

	al
	10

	ed
	14

	jo
	18

	ed
	16





· Place the cursor anywhere in the table that you wish to sort.

 (
Choose the Data Tab on the ribbon. 
Then the Sort & 
Filter  Group
 then….
)




 (
…Click this for a simple sort.
)


The table should appear sorted as follows.





 (
Tip: 
Crl
-Z will undo.
) (
(Note that Jo has still got his 20!)
)

(In order to sort in descending order, we would choose the Sort Descending button.)










· You may wish to undo the sort by clicking the Undo button. (Or Cntrl-Z)




So far a simple sort. We may wish to also sort the second column as follows.

To Perform a More Complex Sort

We wish to sort by the first column and then the second column.



· Place the cursor anywhere in the table that you wish to sort as above.
 (
From the 
Ribbon
,
 
cho
ose 
D
ata, 
S
ort…
)






 (
Note Excel here assumes that the first row is a header. The first row on your table is not selected– and correspondingly this checkbox is checked
)










 (
Choose name.
)


 (
Choose
 Add Level
 
(
not OK yet
!)
)








 (
Choose 
amount
 
then
 click OK.
)





 (
Note that the amounts for each individual person are also now sorted as well. (But Al has still got his 10 etc.)
) (
Choose name
)


[bookmark: Filtering]
Filtering					
· First make the following table:		    ie
	STORE
	DEPT
	SALES

	New York
	Food
	10000

	
	Clothing
	20000

	London
	
	3000

	
	
	12000



	

 (
Make sure that your cursor is in the “table” and on 
the 
D
ata
 tab choose 
F
ilter.
)







 (
The drop arrows appear on the field names as below.
 
)












 (
It is probably best to
 uncheck (Select All)
 first
 choose 
say
 
only the 
London
 Stores.
)














· To restore all the data, click on the filter drop arrow and choose (Select All).

You could try filtering other data.
· To remove the filter altogether, choose the Filter button on the ribbon again. 
[bookmark: SubTotals]
Subtotals		
				
· First make the following table and place the cursor in it. 

 (
The data must be sorted 
(on Store in this case) 
first.
)








 (
In the Data Tab on the ribbon in the Outline group choose Subtotal.
)


 (
(Repeat all of this but with some data to the right somewhere for experiment. You will find that it becomes messed up!). This is a shortcoming of 
SubTotals
.
)







The table becomes highlighted and the following dialogue box appears.




 (
Make sure that these options are chosen and then click OK.
)


















When the sub-totalled table appears,
note the little 1,2,3 on the left of the sub- totalled table.

· Click these to investigate their effect.

· To remove the subtotals, click on Data , Subtotals..., Remove All.
[bookmark: GoalSeek]Goal Seek								

The Goal Seek command will automatically change one of the values in a cell to reach a target value (of 9 in this case – see below). 

· Make a table which simply adds 6 plus 4.  Use AutoSum to add them.



Let’s say that we set the total of the two numbers to be 9 instead of 10 and request Excel to adjust cell A2. (i.e. Excel would need to set cell A2 to 3.)

· Make sure that the cursor is in cell A3.
· In the Data Tab, What-If Analysis then Goal Seek. 
The following dialogue box appears.

 (
This is the cell we wish to set to 9
.
) (
Click here and type 9.
) (
This is the cell that we wish 
Excel  to
 change for us. 
Type A2.  (You could instead click on the cell A2).
) 
 (
Click the OK button.
)


After a while you should see 3 appear in A2!

 (
Goal Seek can also be used to solve mathematically intractable problems
!
 
eg
 findin
g
 IRR page 7 
Benninga
.
) (
Click the OK button.
)
(This is a very simple example. A more complex example might be where wanted to set the vat for week1 (in a previous exercise) to be say £40 by changing one of the values - say Monday’s.)

Quick Data Entry

· 
Type the two entries ed and jo as below and move the cursor to the cell beneath and then right click.

 (
Select Pick from List.
)
When the drop box appears, as below, choose an entry.


eg ed will be entered as below:


· 
To make an entry exactly the same as the one above, click Ctrl ‘. (The Ctrl key and the apostrophe key) Try it.


· In the cell beneath, type the letter j.
 jo will appear. To accept it, press Enter. If you wish to type something else, just keep typing.

· To turn this option on/off choose (Tools, Options…, choose the Edit tab and check Enable AutoComplete for cell values.

[bookmark: Link]
To Link Two Worksheets

Quick Method:
Type = (equal) on Sheet1
Select a value on Sheet2. 
Press Enter.
 (
Note the formula which appears in the Formula Bar at the top. (We might well have typed this formula long-hand.) Note the exclamation mark which always follows a sheet name.
)










Now change the value in the first sheet. The value in the second sheet should change automatically to the same value.

We could also type this formula in longhand!


Alternatively Copy and Paste Special (long method)

 (
Paste Link
)


















To Insert a New Worksheet









 (
Right-click in the sheet tabs at the bottom of the workbook and choose Insert and then
 
Worksheet and click OK.
)




 (
A new worksheet appears.
)








To Move a Worksheet
















[bookmark: IF]
The IF Statement

· Type the formula

 = if(A1>A2,"bigger","smaller")

into cell C2 along with the two numbers 20 and 30 as shown.


= if(A1>A2,"bigger","smaller")

 (
If this is a 
true
 statement (which it 
is
 in this case since 
40
 is larger than 
30
) then the 
first
 "alternative" which is 
"bigger" 
is "selected" otherwise the 
second
 statement is selected
Rule: The first alternative is chosen if the statement is true. 
The second alternative is chosen if the statement is false.
)






· Change the 40 to 20. You should find that the 2nd alternative ("smaller") appears in cell C2.

The "alternatives" need not be text as in "bigger" and "smaller". 
They can be numbers – or cell references as shown here:


(In practice, cell C2 could indicate a change in commission for a salesperson if his/her sales went above 30.)

For If exercise see page 25 of Manual 3 (xlExtraToDay1And2FinalVer1.doc)

Excel Exercises: http://www.abacustraining.biz/ExcelExercises.htm
 (
Shop assistants earn £12.
50  per
 
hr
 if they work over 30 
hrs
 otherwise they get £10.50 for 
hrs
 under 30.
If they work 40 
hrs
 how much do they get?
(
ans
 £440 as shown here.)
If they work 20 
hrs
 how much do they get?
 
(
ans
 £210)
The Excel formulas should handle all situations as above.
Hint Use two 
IF’s
. Make one IF formula for the “
ordinary
” 
hrs
 and another IF just for the 
overtime
 hrs. 
)
	hrs
	40
	
	

	ot lim
	30
	
	

	
	
	rate
	tot

	ot hrs
	10
	12.5
	125

	ord hrs
	30
	10.5
	315

	
	
	
	

	 (
AddressExpt.xlsm lesson sheet
)
	
	total pay:
	440


YouTubes


-----------------------------------------------------------------------------------------------------------------

Manual 1st Day Videos

· YouTube ExcelBegLesson1a: https://youtu.be/HS7beDaFNzQ
Entering Data	Editing	Simple Formulas Quick method of entering a formula			
Series Formulas To Insert a New Row To Insert a New Column	To Format Headings		
Copying Formulas

· YouTube ExcelBegLesson1b: https://youtu.be/HXRh9pvobm8
Absolute Reference Charts Formatting Numbers	

· YouTube: ExcelAdvLesson2b: https://youtu.be/mPP_YN7Qlfs
Sorting			0:28
Filtering	 		3:14			
Subtotals		5:25
Link Worksheets	11:11	
Goal Seek		 8:05			
The IF Statement	23:49

	

Manual 2nd Day

· YouTube  ExcelAdvLesson2c https://youtu.be/Ptxg-urzBUc
Vlookup					 0:13 
PivotTables					 8:01 
Macros: (next manual)				11:52
· YouTube ExcelAdvLesson2d.avi https://youtu.be/OSd6h2SXcjM
Scenarios					0:19
Solver 						2:47
Conditional Formatting				6:20
Names						8:23

----------------------------------------------------------------------------------------------------------

Manual 3rd Part

Names			8:23

---------------------------------------------------------------------------------
https://trumpexcel.com/unique-items-from-a-list-in-excel/



[bookmark: templates]
Templates

Templates contain fixed headings.

A template is used to create documents containing these fixed headings.

For example, we may have monthly expenditures as shown. 


 (
Use your own current spreadsheet instead if you wish.
) (
Create these headings and change the name of the sheet to expenditure.
)







 (
In Excel 2007 we have the “Office Button” instead of “File”.
)
We wish to save this as a template.

 (
Excel 2010
.
)

 (
Choose 
F
ile, Save 
A
s…
)




 (
Note that the Templates folder is automatically chosen. Take care with this.  This can be a source of confusion.
)








 (
Name it 
MonthlySales
.
)

 (
Choose Template(*.
xltx
)
 (
or
 
xltm
 if macro-enabled).
)





 (
Note the name of our template at the top.
)
 (
Close it.  File, 
Close
.
)







We now wish to make a spreadsheet based upon this template.









 (
Chose 
File, Ne
w.
 (
NOT File, Open!
)
)




 (
Choose My templates.
)












 (
Double-click on our template.
)






 (
Note the temporary default name of the document.
)
A document opens:



 (
This is a document 
based upon
 our template.
)









 (
Fill in some data for this month.
)







· Choose File, Save As…

 (
Ensure that you are saving it as an .xlsx.
 Give it a name and click 
S
ave..
)





· Close the spreadsheet.

· Create another spreadsheet based upon out template by choosing File, New… once again.






 (
This time 
you could choose My temp
lates again or choose it from Recent templates.
)











 (
A spreadsheet based upon our template opens. Note that it is a “tabula rasa”.
)







· Enter new figures and save it as February.xlsx.

Things to remember:

When making a template, save it as an .xltx (or xltm).

When using our template, choose File, New… and not File Open…

We would use File Open…if we wished to alter the actual template.

[bookmark: scenarios]
Scenario Manager							

Scenario Manager enables you to “try out “a set of values and watch the effect they have on some value which has been calculated using a formula.

We can save one or more sets of these trial values under a name and then call them at will.

Look at the table below.

We are going to try a set of values which we will call best.
The value of Sales will be 20 and the value of Costs will be 2.
The other scenario will be called worst ; the value of Sales will be 8
and the value of Costs will be 1.

First the Sales will be 10 and the Costs 5 and in cell B3, type the formula  = B1-B2 in order to calculate the Profit.







On the Ribbon choose the Data tab and then Scenario Manager.

The following dialogue box appears:





 (
Click 
Add
 
)







 (
Click in here and type say 
best
.
)






 (
Click in here and then select the range 
B1:B2
 by dragging the range 
B1:B2
 on the spreadsheet.
)






· Click OK


 (
Type 
20
 
in here.
)



 (
Click in here and type 
2
.
)






· Click OK

· Repeat the above to produce another scenario called worst using the values say 8 and 1. Finally , Click OK,

 (
Select the scenario 
best
 and click the 
Show
 
button to change the values in the table.
)To try each scenario:












The following scenario should appear:











· In the Scenario Manger dialogue box choose the worst scenario

The following scenario should appear::













 
[bookmark: pivot]Pivot Tables								

A Pivot table is an alternative way of viewing data in a table. It relies upon having repeated data in columns and using these repeated data to make row and column “headings”.

· First make the following table.		Data for pasting:
	Store
	Dept
	Sales

	New York
	Food
	10000

	New York
	Clothing
	20000

	London
	Food
	25000

	London
	Clothing
	25000






We will make the following pivot table from the above table As well as re-arranging the data a  Pivot Table produces subtotals as shown in the table below.



We will now produce the above Pivot Table.

· Place the cursor anywhere in your list (a list is a table of data).
· On the Ribbon choose the Insert tab and then the Tables group.

Choose Pivot Table






				


 (
Click OK.
) (
Take care to choose Existing Worksheet.
Click on the sheet to choose a location.
)


 






 (
If your pivot table designer disappears, click in your table on the spreadsheet.
) (
Check (tick) these fields.
)

 (
If you 
take a look
 at the pivot table that we are trying to produce (see below), you will see that 
Dept
 should be in the Column Labels and
Sales
 in Values leaving
Store
 in Row Labels.
 
Drag these accordingly.
)







The Pivot Table should finally appear as below:













[bookmark: solver]
Solver									

Solver is similar to Goal Seek but it allows us to change more than one cell to achieve say a goal.

· Set-up the table of numbers as in the diagram below. Use AutoSum to add the 6 and the 4.

Let’s say that we wanted a total of 9 instead of 10 but this time we wanted Excel to adjust both numbers to reach that goal. In this case however we also need stipulate how these two numbers are to be constrained. Let’s say that we simply wanted them to be equal.
(Excel would therefore need to obviously provide the solution of 4.5 and 4 5.)

	
 (
If Solver is not available:
Click 
File, 
 Options
, 
 Options is not always easy to 
find..
You may need to scroll down to find it.
and then click 
Add-ins
 
and 
select the 
Solver Add-in
 
check box, and then click 
Go….
Check Solver Add-in then click 
OK.
.
 
)













Solver should appear in the Analyze group: Click it (After placing the selection into A3.)
 







The following dialogue box should appear.

· Select cells A1 and A2 by clicking on cell A1 and dragging to A2.
 (
Click here.
)

 (
Type 
9
)

We now need to set the constraint that A1 should be equal to A2.


· Click on the Add... button. 







The following dialogue box should appear.
 (
Click here
)

 (
$A$1
 should then appear here.
)


 (
Click in here.
Click on cell 
A2
.
$A$2
 should appear here.
) (
Click on this drop arrow and then chose the 
=
 sign.
)

· Click on the OK button.

The Solver Parameters dialogue box should re-appear.










· Click the Solve button.






You should get the following result:











· Click the OK button to keep the solution or cancel to return the status-quo.



More Complex Solver exercise: 





[bookmark: conditional]
Conditional Formatting

· Take note where your cursor is:






On the Ribbon, choose the Home tab and in the Styles group.









 (
Highlight Cells Rules, Greater 
Than..
)








 (
Choose 
say
 10.
) (
Choose a formatting and then click OK.
)







· Now if we type a number greater than 10 its formatting will appear as:






Whereas tying a number less than 10 will not:


 (
Choose Conditional Formatting.
)



[bookmark: vlookup]
VLookup YouTube: ExcelAdvLesson2c https://youtu.be/Ptxg-urzBUc 	0:13secs

Excel VLookup Macros PivotTables 	
	10
	55

	20
	65

	40
	75

	30
	65



· Make the following table and type the formula 

=VLookup(40,A1:b4,2,False) into say cell D1.




=vlookup(40,A1:b4,2,False)



 (
A1:B4
 is the range we are searching 
) (
40
 is the number in the first column that we are searching for.
) (
We wish to find the corresponding number in column number 
2
.
(Of course, there may be more than 2 columns.)
)






 (
The 
False
 in the formula indicates that we are looking for an exact match (see next page.)
)





Hlookup is used when we want to search down a column instead of across a row.
The 3rd number in the formula (the 2 in the above formula) will then be the number of the row to be searched.







The Meaning of the False in the Formula

For example try looking for 35 instead of 40 using VLookup.
An #NA message will result because an exact match could not be found as shown below.










What if we are happy to find a value corresponding to the value which is just below (in value eg 30) the one we are looking for?

We must do two things: (do this)

· 1. Sort the data. 

· 2. Change the False to True (or omit it – it’s the default)










 (
30 is smaller than 35 and hence 85 is returned.
)





Good YouTube:
https://exceljet.net/tips/how-to-use-vlookup-for-approximate-matches

Xlookup is more versatile














Data Validation

 (
 On the Ribbon choose the Data tab and then the Data Tools group and then Data 
Validation..
)


 (
Click the 
Error Alert
 tab and then type in the message that you wish to appear when invalid data is entered and then click 
OK
...
)





 (
365: Data Validation!
)








					Expanded view.




 (
Choose
 Whole number between 1 and 5.
)


















 (
Now when we enter data which 
doesn’t
 satisfy the 
criterion
 we will get the following message in a dialog box.
)













[bookmark: comments]Comments
 (
On the Ribbon choose the Review tab and then the Comments group and then New Comment.
)












· Type in the comment.

 (
Note the appearance of a little red triangle to indicate that the cell has a comment associated with it.
)
From now on, every time that we click in this cell the comment box will appear.

To make comments always appear choose from the menu File, Excel Options and then..





 (
Make a choice from here.
)




For this particular workbook we can choose :

 (
Show all comments.
)





To PRINT the comments (when we print the spreadsheet.):


 (
Click the little arrow and then choose Sheet, Comments, As Displayed on sheet, OK,
)





365: Comments has been replaced with Notes


To Set the Print Area

· First select (only) the area that we wish to print.










 (
On the Ribbon choose the Page Layout tab and then the Page Setup group.
)















 (
Note the dotted boundary.
)




· Change to Print view. (File, Print)





 (
Now only our selected numbers will be printed.
)









To Remove the Print Area

Choose the Page Layout tab, Print Area, Clear Print Area.






Page Break Preview

 (
On the Ribbon Choose the View tab and then the Workbook Views group.
and then Page Break Preview.
)












Your data should appear in Page Break Preview along with maybe a dialog box telling you what to do.








 (
Take note.
)






To Return to Normal View:

 (
From the View tab choose Normal from the Workbook Views tab.
)







To Insert a Page Break

Place the cursor beneath (or to the right of) where you wish the break to occur.


 (
From the Page Layout, Breaks choose Insert Page Break.
)






· To break the page vertically, place the cursor to the right of the required page break as below.










· To simultaneously break the page vertically and horizontally, place the cursor to the right and below.










To Remove a Page Break

· Place the cursor beneath the Page Break.

 (
Page Layout tab, Beaks, Remove Page Break.
.
)














Header and Footer

A header is something which appears at the top of every page (perhaps the company name).
A footer is something which appears at the bottom of every page (perhaps the page number).

For the purpose of the exercise, make sure that you have more than one page and also name it (eg test.xlsx).

We wish to make a footer which will show the name (test.xlsx) of the document.

On the Ribbon choose the Insert tab and then the Text group.







 (
Select 
H
eader/Footer…
)





 (
Type in your header.
)





If we now choose File, Print..
 (
.. the header will appear on each page.
)







A little obscurely, if we wish to exit from this Header view we must….



 (
… choose View, Normal.
)






Quite bizarrely if we want to modify the header then we must choose Insert again.

· Try it.




To Insert a Footer

As before choose Insert, Header & Footer
but now choose Go To Footer.



We can choose to put the name of the spreadsheet as a footer:







 (
Choose Footer form the Header & Footer group and the choose our spreadsheet name.
)








· Preview our spreadsheet .

 (
The name of your file should appear at the bottom of each page. 
)







[bookmark: mergeCentre]Merge & Centre:

 (
Select two cells. 
)






 (
From the Alignment group on the 
Home
 tab choose Merge & Center (sic)
)





 (
The cells are merged and 
centred
. 
)



Experiment with the Wrap Text feature above.
To Apply a Border

· First select the cells around which we wish to place a border as below








On the Ribbon choose the Home tab and then the Font group





 (
Either choose from here 
or..
) (
.. choose More Borders.
)










 (
Choose 
Border.
)


 (
First
,
 choose the border line and its 
colour
.
)






 (
Then
, choose the type of border and click 
OK
.
)







· Choose preview (File, Print) to view our border which should appear as below.









To Turn the Gridlines On and Off

There are two types : The ones visible on the spreadsheet  itself and the ones for printing.

 (
Choose the Page Layout tab on the Ribbon.
Check the View or Print boxes. Note the explanation.
)





Aternatively:














For permanence ie for future spreadsheets: For Excel 2010: Choose File.
(Excel 2007 Choose the Office button) and then Excel Options.















 (
Uncheck Show Gridlines.
) (
Choose Advanced
.
)







 (
The gridlines disappear.
)


[bookmark: SolverMore]
More complex Solver Exercise:

See Sheila.xls & notes.





















https://support.microsoft.com/en-us/office/using-solver-for-capital-budgeting-dff4743d-72e4-49d5-a917-19d437efae88

Go to Solver > Options > Uncheck "Ignore Integer Constraints" Thanks for other forum help!

[bookmark: Xlookup]
XLookup				cf vlookup

https://support.microsoft.com/en-us/office/xlookup-function-b7fd680e-6d10-43e6-84f9-88eae8bf5929


Exact match is the default.    		cf  approx.match is default

By specifying ranges rather than range and column number xlookup can work “backwards”.

	10%
	9700

	22%
	39475

	24%
	84200

	32%
	160726

	335%
	204100

	37%
	510300




Can return more than one column data.

Column to search IN.

=XLOOKUP(20,A1:A4,B1:C4)

	10
	55
	100
	
	65
	120

	20
	65
	120
	
	
	

	40
	75
	110
	
	
	



[bookmark: spill]
Spill

Type =SORT(D2:D4,1,-1) into cell E1 only.

	622
	961

	961
	691

	691
	622



Excel will return a #SPILL! error indicating that there is a obstruction

=UNIQUE(B2:B11)

	1
	
	1

	1
	
	2

	2
	
	3

	2
	
	4

	3
	
	5

	3
	
	

	4
	
	

	4
	
	

	5
	
	

	5
	
	



The exactly once argument set to TRUE, the function returns uniques which appear only once in the original table.

=UNIQUE(A1:A4,,TRUE)

	ed
	jo

	jo
	al

	al
	

	ed
	



Looks like Cntrl-Shift-Enter is redundant.

 (
Type 
=F2:F11*G2+G11
ONLY in here and it spills down.
)
	1
	1
	6

	1
	1
	6

	2
	2
	7

	2
	2
	7

	3
	3
	8

	3
	3
	8

	4
	4
	9

	4
	4
	9

	5
	5
	10

	5
	5
	10

	


	
	






















Whereas Ctl-Shift Enter means only ONE resuly (top right) appears)

Th @ does he same thing. Ie the @ sign reverts 365’s behaviour.

=@F2:F11*@G2:G11




[bookmark: ToNameARange]
To Name a Range							

A Name is given to a range of cells that we use often. We could give it a name, Sales for example.

We can then use that name in a formula.

 (
Then type the name of the Name here and 
Press Enter
 - don’t “click away”
)Quick way:



 (
First select the range that you wish to name.
)




.



 (
Place the cursor in say cell C4 and type:      
= 
sum(
Sales)
. The sum should appear as shown.
)





 (
From now on, if we wish to select this 
range
 we can choose Sales
 
from this drop box.)
)






Hints: 	1. Individual cells can be named. eg name cells a, b & c and then they can be used in a formula  eg = 2 * a * b + c.

2. If we try to name a cell which is adjacent to a cell with text in it….
 (
Ctrl-Shift F3 will deal with a column of names
 in one go
! 
 (Select Left Column)
) (
… Excel has a guess at what you want to call it!
)






[bookmark: Formulas] (
Don’t 
select
 the name
 or 
else the old range will also be 
selected!
) (
.. take care to 
re-type
 the name in the Define Name dialog 
box .
)Beware: When re-defining a name – selecting a new range on the s/sheet and giving it the name..
Formulas				

To Find the Average

· Type in the 3 numbers as shown below. (The average of these 3 numbers is of course 2.)
 (
FormulasTab
 on the ribbon. 
Insert 
Function.
.
) (
Click the 
Function Wizard
 button.
)
 (
Select cell 
C4
.
)









 (
Select Statistical.
)



 (
Select AVERAGE.
) (
Click 
Finish
.
)







 (
Click OK.
)



 (
The range of numbers to be averaged should appear here. If it doesn’t, click the little coloured square (this removes the dialog box so that you can see the range required on the s/sheet itself in order to select them To return to the dialog box, click the little 
coloured
 square 
again..
)












 (
(Note the appearance of the formula - which might just as easily be typed in
! )
)




 (
The average of the 3 numbers which is 
2
 should appear here.
)



[bookmark: FormFinancial]
Formulas (Financial)		. 

Let’ say that we take out a loan for £2000.
We wish to pay off the loan in one year - making 12 monthly payments.
The interest rate we are told is 10%.
How much do we have to pay back each month?
This is a complicated calculation since we are paying interest on the amount left to pay!
The answer is £175.83 per month)
 (
Formulas Tab
Insert Function 
)
Let’s get Excel to work it out.

· Make up the following table



 (
Type the interest rate 
per 
period
  ie
 
=10%/12
.
)



 (
Select the cell where you wish to answer to appear here and then click the 
function wizard
 button   
  .
 
)








 (
Select 
Financial
.
)


 (
Select 
PMT
.
)






 (
Click OK.
)








 (
Alternatively
,
 you could just type in:
=PMT(C
2,C
3,C4)
Probably easier!
)











 (
Click in the respective boxes and corresponding s/sheet cells to include the references as shown.
)









 (
Click OK.
)




 (
The repayment should be calculated. (Red indicates that a payment must be made.) (
It
 is common practice to make the loan amount negative 
ie
 -2000 in this case.
)
)







Exercise:

Calculate the total interest paid. What percentage is this of the 2000?. Why is it less than 10%?

Optional: Make a table (an amortization table) to show the monthly payments, the interest accrued for that month, the corresponding loan amount still outstanding and the monthly payment (which could be further split into interest payment and principle repayment.) The amount outstanding must be zero at the end of the 12th month.














[bookmark: FittingData]
Fitting the Data onto One Printed Page

For the exercise, drag some data so that 4 pages are being used.
 (
Page 
Layout  Tab
Click arrow to get 
the
     
Page Setup dialog box.
)







 (
Drag a fill handle until we reach about cell K60.
)








 (
Page breaks are indicated by the dotted lines.
If dotted lines are not visible go to File, Options. Advanced, Show page breaks.
)







· Select File, PageSetup… from the menu bar.







 (
Choose 
F
it to
 
1
 by 
1
.
)












· If you take a look at your spreadsheet, the dotted lines(page breaks) should have disappeared.

· This can be confirmed by clicking View, Page Break Preview. 

Worksheet Protection

We can protect the whole sheet as follows:

 (
Choose the Review tab and then Protect Sheet. 
(
There is also the option to protect the whole Workbook
.)
)





But what if we don’t wish certain areas/values of the sheet to be protected and others unprotected?

· Chose the cell/range that you don’t wish to be protected.

· Format a cell as Unlocked, right-click on it and choose Format Cells. (Or on the ribbon from the Format tab on the Cells group) etc.

·  (
Protection 
and..
)Choose Format, Cells…  and…


 (
.. 
uncheck the 
L
ocked property
 for these cells
.
)

Now after protecting the sheet (as shown at the top of this page) we find that we can then only change the unlocked cell/s.
 (
Try changing any other cell.
)






So, unlocking cells produces a “mask” of unlocked cells.

[bookmark: WorksheetProtection][bookmark: OLE_LINK1][bookmark: OLE_LINK2][bookmark: PivotTablescon]Unprotect the whole sheet before proceeding.
Pivot Tables cont'd

You should now have the following pivot table.

· If not, copy into Excel from this table and make the pivot table below.

	Store
	Dept
	Sales

	New York
	Food
	10.000

	New York
	Clothing
	20,000

	London
	Food
	25,000

	London
	Clothing
	12,000



 (
New York 
and
 
London
 are referred to as 
Fields
 
whereas Clothing and Food which 
are
 "headings"
 
taken from the 
body
 of the table 
are known as 
Items
.
)
 (
Note the 
drop-down
s
 
for the Rows and Columns. Try them.
 
)

 (
Can you see why 
its
 called a “pivot” table? Because the Items 
ie
 Food & Clothing “rotate” 90 degrees about their top cell.
 
)

 (
Change 
the 1200
 to say 
15000
 in the original table of data.
)To refresh the pivot table




Notice that the pivot table does not automatically update.

· Make sure that the cursor is in the pivot table.

· On the Pivot Table toolbar, click Pivot Table, Refresh. Or Right-click and choose Refresh.







Notice how the new Ribbon group for the Pivot Table appears when the cursor is in the pivot table:

					eg we could Refresh using this.      Excel 365:


The pivot table data should now appear refreshed as below:










To Add a New Data Row
 (
Type in a new row of data. We 
now 
wish to update the pivot table.
)










 (
W
ith the 
cursor in the pivot table
, choose Options,
 Data
 tab
,
 
Change Data Sourc
e
 from the context Ribbon.
)




 (
Update to the new range and then click OK.
)












 (
The pivot table is updated.
)




· To remove fields, simply click in the pivot table.  Uncheck them in the PivotTable Field List dialog box (If this is not visible right-click in the pivot table and choose Show Field List) or uncheck the fields in the Row Labels drop-down.

· Moving the pivot table. Simply drag it!
		
· Removing Grand Totals. Right click on “Grand Total”!  in the pivot table and choose Remove Grand Total.


Pivot Table Options can also be obtained by right-clicking on the pivot table and choosing PivotTable Options eg “Totals & Filters” will give access to Grand Totals.

· Interchange the Store and Dept fields:. 

Simply drag them across in the PivotTable Field List dialog box.

Changing Your View of the Data Using Page Fields

· Make sure that the cursor is in the pivot table. Then -  in the Pivot Table Field list:


 (
Right click on Store and choose Add to Report Filter.
)







 (
(
Alternatively
 
just 
drag 
the field
 
here
.
)
.
)









 (
To select a different "page" 
select
 
London
 or 
New York
,
 
and
 click OK.
)Your pivot table should now look like this:








Changing the Summary Function for the Data

 (
At the moment
,
 these are totals (sums).
Say we wanted to find the 
maximum
 in each respective row and column.
)



















 (
Right-click
 in the pivot 
table 
 and
 choose Summarize 
Values 
 
B
y
 
and 
then 
choose Max for example.
)








 (
This is now the maximum value in the row etc.
)
























Changing the Data to Percentage (of Total)















Result:




For the next exercise:

· Restore the pivot table.


To Insert a Calculated Field

It may be simpler to include a calculated field in the original data source but maybe that is inaccessible.


 (
We wish to insert a VAT column for Food.
)
<- 365



 (
First make sure that your cursor is in the pivot table
.
 
– actually in an
 Item 
heading
 
(
ie Food
) 
.
 
Fro
m the 
Options
 tab on the 
(Pivot Table
 Tools
) R
ibbon, 
choose
  
 
Fields
 Items & Sets
 ..
, 
Calculated 
Item
.
. 
)






· Fill in the dialog box as below and click Add.

 (
Give our new heading a name.
)





 (
(
Hint: 
Rather than 
type
 “Food”
 when constructing the 
formula
 
it may be easier to double-click on
 
it 
here.
)
)










 (
Click OK.
)
 (
The new field is inserted.
)









 (
To remove the calculated field, 
From the Options tab 
(
M
ake sure that your cursor is in the pivot table)
 – actually the 
c
ursor needs to be in Item heading
 
(
ie
 Food) 
O
n the ribbon, choose Fields
 ..
, Calculated 
Item
.
and the
n the
 
D
elete button and click OK.
) (
Make sure hat the field that you want to delete is chosen.
)

To Hide Pivot Table Items

We wish to hide the Clothing field









 (
Uncheck the 
Clothing
 check box.
)










 (
Click OK.
)



You should find that the Clothing field is hidden as below:









Note that the totals change. They do not take into account the hidden fields.



To Unhide a Hidden Field

· Repeat the process – choose the Dept drop down but check the Clothing check box.

Displaying the Source Data for an Item in the Pivot Table

· Double-click on a data item.


This should produce the following data - on a separate sheet!








This is giving an indication of how the figure of 25000 was derived!


 (
Hide Detail
 when we have more than one row heading or more than one column heading.
See page 
514 
?
 
Excel manual.
)
Sorting : Click A-Z.

Charting : Remove the Grand Totals first.









Changing the Name of Fields:

· Right-click  on the field name that we wish to change in this case Dept.

 (
Its easier just to type it in!
Type it in the formula bar.
)









 (
Choose Field Setti
n
gs…
)



 (
Change the name and click OK.
)






(This changes the field name in the pivot table only not in the original table.)




















Grouping Items 



	Store
	Dept
	Sales

	New York
	Food
	10000

	New York
	Clothing
	20000

	London
	Food
	25000

	London
	Clothing
	12000

	New York
	Beverages
	23000

	London
	Beverages
	12000



 








First produce this pivot table.










We wish to group the Beverages and Food categories (and call them Consumables).

· In the pivot table highlight the Beverages and Food categories (use the Crtl-key if they are not contiguous).

· Then Right-click on one of the selected categories and choose Group,


 (
The new group heading (Group1) appears.
Change it to 
Consumable
s
. (Click on it and 
change it in the 
formula bar
. (S
ee below for the result)
)



 (
Note the appearance of a new field – a 2 is append
ed - in this case to give Dept2?
 
)










or may look something like this in Excel 2007+
To Hide Detail


 (
Double-click on the group heading (Consumables)
….
)


 (
(Alternatively, use the Hide Detail menu command from the short cut menu or the Hide Detail button on the pivot table toolbar.)
)









 (
…t
he two columns are summarised.
)











· To unhide, double-click again.









Exercise: 	Add to the table as shown below…

	Year
	Store
	Dept
	Sales

	1991
	New York
	Food
	1000

	1991
	New York
	Clothing
	20000

	1991
	London
	Food
	25000

	1991
	London
	Clothing
	12000

	1991
	New York
	Beverages
	23000

	1991
	London
	Beverages
	12000

	1992
	New York
	Food
	10000

	1992
	New York
	Clothing
	20000

	1992
	London
	Food
	25000

	1992
	London
	Clothing
	12000

	1992
	New York
	Beverages
	23000

	1992
	London
	Beverages
	12000



…and produce the corresponding pivot table:




 (
(Right-click and 
choose Field S
ettings. Choose
Layout & Print then “Show item labels in tabular form.)
)

.


Exercise: 	Double click on the years (1991 & 1992) to hide the detail.


To Hide Subtotals






 (
We wish to remove these subtotals.
)











 (
Right-click on one of them and choose 
F
ield Settings…
)























The dialog box which appears is a little different to that which appeared before….




 (
…it has a Subtotals section.
Choose None.
Click OK. 
)









Subtotals gone:






(Recall that Grand Totals are switched off through Table Options.)









[bookmark: Slicers]
Slicers 		(New to 2010) 

First make the pivot table from this table.

	Store
	Dept
	Sales

	New York 
	Food
	10,000

	New York 
	Clothing
	20,000

	London 
	Food
	25,000

	London 
	Clothing
	12,000



· With the cursor in the pivot table, from the context ribbon menu Options choose Insert Slicer.

















 (
Choose say Store and then click OK.
)





 (
When the slicer appears, choose say London.
)






The pivot table now automatically shows results only for the London Store.







Exercise: Make a slicer for the Dept. 
[bookmark: PivotChart] (You can have both (Store & Dept) slicers showing at the same time)
Pivot Chart


	Store
	Dept
	Sales

	New York 
	Food
	10,000

	New York 
	Clothing
	20,000

	London 
	Food
	25,000

	London 
	Clothing
	12,000



· With the cursor in the table above, choose Insert Pivot chart:











Follow the usual procedure as for the pivot table.

Our pivot chart eventually appears below. 



 (
(
We get a pivot 
table
 for free.
)
)











 (
Pivot chart.
)









[bookmark: ExIf]Exercise: Make some slicers and not how the chart responds as well!

[bookmark: RecEx]Exercise.

· 1. A man works 35 hrs in a particular week. He gets paid £4.00 per hr up to the overtime limit of 40 hrs whereupon he gets paid £5.00 per hr. Manually calculate his wage for that short week.

· 2. Manually calculate his wage if he works 45 hrs.

· 3. Make an Excel formula using an IF statement to automatically give the number of overtime hrs if the number of hrs worked is entered.

 (
eg
 If 
45
 is entered here, 5 must appear here.
)





 (
eg
 If 
35
 is entered here, 0 must appear here.
)




· 4. Make another Excel formula using an IF statement to automatically give the number of ordinary hrs if the number of hrs worked is entered. (You could also use the MIN function)

 (
eg
 If 
45
 is entered here, 40 must appear here.
)



 (
eg
 If 
35
 is entered here, 35 must appear here.
)





· 5. Finally, place a formula in G2 which automatically calculates his total weekly wage.



[bookmark: DataTables]
Data Tables:	

We have a simple formula which calculates the interest of 1000 at 10% as below.
 (
Excel 2007:
 Data tab on the ribbon. 
What If Analysis.
)





 (
We wish to "plug" values into this cell to see the effect of different interest rates.  Such values are provided by a Data Table.  (This cell is called the Input Cell.)
)





To Make a Data Table

 (
First provide the range of values that we wish to substitute.  They could be in a row or column.  We have chosen to use a column.  
)





 (
Secondly – to 
the top-right
 of our column of values, copy the formula 
as shown 
which serves as an 
example
 of the calculation.
)


 (
Select the prospective data table. 
)

 (
From the 
Ribbon
, choose 
D
ata, 
What If Analysis, 
Data 
T
able
…
)











 (
Since the values that we wish to substitute into the input cell are in a 
column
, choose 
C
olumn input cell: 
and choose the cell into which we wish to successively input the values. 
)





 (
Click OK.
)


 (
The data table containing the corresponding results appears.  (It may 
be  aesthetically
 desirable to 
hide
 the "example formula"
 in E4
.)
)


 (
Why use data tables
? You know very well that you can drag formulas, but the problem is that you can only drag “parallel to the data”. Data tables allow you to dra
g “at right angles” to the data!
)




 (
Another
 point of 
using 
data tables
: For a 1-D data table. The formula that we wish to “drag” may be remote from where we wish the result to appear.
)





If the Data To Be Input is in a Row Instead of a Column



 (
Indicate that the data is being substituted from a 
row
 into the input cell by choosing 
R
ow
 input cell:
) (
The "example formula" must be one to the left and one below the data.
)


Two Dimensional Data Table
 (
Now we really see the use of data tables. Think what it would take to construct this 2-D table if we didn’t use data tables.
)




 (
We wish to show the effect of changing the principal amount 
as well as
 the interest rate.
)
 (
C
opy the formula into the top-left cell of our table
.
 
S
elect the table and then choose
 Data, What If Analysis, 
D
ata
 
T
able from the 
Ribbon
.
)





 (
Wrong: Should be other way round.
)
 (
A1 is the Row 
Input cell
 and B1 is the 
C
olumn Input cell
.
)


Row input ie DOWN
Column input ie ACOSS


 (
Click OK.
)


The 2-D Data Table appears.




[bookmark: LookupandReference]Lookup and Reference functions

https://support.office.com/en-us/article/Lookup-and-reference-functions-reference-8aa21a3a-b56a-4055-8257-3ec89df2b23e

		Function 
	Description

	ADDRESS function 
	Returns a reference as text to a single cell in a worksheet

	AREAS function 
	Returns the number of areas in a reference

	CHOOSE function 
	Chooses a value from a list of values

	COLUMN function 
	Returns the column number of a reference

	COLUMNS function 
	Returns the number of columns in a reference

	FORMULATEXT function 

	Returns the formula at the given reference as text

	GETPIVOTDATA function 

	Returns data stored in a PivotTable report

	HLOOKUP function 
	Looks in the top row of an array and returns the value of the indicated cell

	HYPERLINK function 
	Creates a shortcut or jump that opens a document stored on a network server, an intranet, or the Internet

	INDEX function 
	Uses an index to choose a value from a reference or array

	INDIRECT function 
	Returns a reference indicated by a text value

	LOOKUP function 
	Looks up values in a vector or array

	MATCH function 
	Looks up values in a reference or array

	OFFSET function 
	Returns a reference offset from a given reference

	ROW function 
	Returns the row number of a reference

	ROWS function 
	Returns the number of rows in a reference

	RTD function 
	Retrieves real-time data from a program that supports COM automation

	TRANSPOSE function 
	Returns the transpose of an array

	VLOOKUP function 
	Looks in the first column of an array and moves across the row to return the value of a cell



	


[bookmark: Choose]

Choose
 (
It
 chooses the 2
nd
 option which is 
tue
.
)






Doesn’t like =CHOOSE(2,B2:B6)


Row and Column




Address 	Returns a physical address.










Offset

 (
The value which is at offset 1 row and 1 column from B2 is 43.
)







OFFSET(reference, rows, cols, [height], [width])

Optional [height] & [width]s refers to size of the range which is offset.

eg Make a formula which sums 3 values which are offset 2,1 from cell B3 and are of size 3,1.

=OFFSET(B3,2,1,3,1)

 (
The sum of the 3
,1 column 
of 
 numbers
 
which are located at 
 
offset (2,1) from B3.
)


[bookmark: Index]

Index	: 

Reference an element in an array by its indices (Row, Column).



 (
Index gives a 
value
.
)we can just specify ONE index in a row (or column) say C1:C3 eg =INDEX(C1:C3,2) would return 4 in this case. (2 is the row number here.)

[bookmark: IndexContd]
Index     contd. This also illustrates an   Array Formula		 
 (
The 
1
, 
0
 means 
every
 column element in the row
 
1
 is displayed.
) (
“
0 means 
every
.” 
)		

 (
=
INDEX(
F2:G3,
2
,0)
 Every element in row  
2
 would be displayed..
)



 (
An Array formula is mainly used when we have a 
series of values resulting
.
They are apparently sometimes called CSE (Control-Shift-Enter) formulas.
)




 (
Enter this as an array formula. (Ctrl-Shift-Enter.) 
)

 (
0
, 
1
 
means 
every
 row
 
element in the column
 
1
.
)










We could of course the use the SUM formula on this reference above. eg 
=SUM(INDEX(F2:G3,0,1)   ->  3
 (
…then as well as specifying the row, 
column  eg
 row 2 column 1…
)
The “reference” form of Index:
If multiple areas are specified:
 (
we need to specify which area 
eg
 area 2.
)
 (
This is the 2
nd
 area specified in the above formula 
ie
 Area 2.
)
result will be:  row 2 column 1 of the 2nd area -> 2.
[bookmark: Match]
Match

MATCH finds the relative position of an item in a range.

Exact:
=MATCH(23,C1:C4,0) 0 means that an exact match must be found.
 (The data need not be sorted.)








 (
Row 4 is returned because 23 is an exact match for 23
 in the formula
.
)


Less Than:
=MATCH(23,c1:c4,1) : The 1 (or omitted ie =MATCH(23,C1:C4) ) means that a value less than what we are looking for will suffice. The data must be sorted in ascending order.
So if we look for 24:









 (
Row 3 is returned because 23 is the first number less than the 24 in the formula.
)



=MATCH(24,c1:c4-1) : The -1 means that a value bigger than what we are looking for will suffice. The data must be sorted in descending order! So if we look for 24:




 (
Row 1 is returned because 25 is the first number bigger 
than the 24 in the formula.
)




Exercise: Use Match and Index to emulate this VLOOKUP below.
 (
(
Remember that False indicates that an 
exact
 match must be found.
)
)







Do this in three stages: (Remember we are looking for jo’

1. First find the row number of jo in the first column using Match.



 (
Remember:
 
 
0
 means that an exact match must be found
(O
r 
omit it:
 U
se 
MATCH("jo
",A1:A
3
).
)

 (
jo is in row 2
.
)


2. Now use this value of 2 in the above Index formula.
 (
W
e are here using the result of 
our MATCH in D2
 
ie
 the 2 
- 
fed into the INDEX formula
)




 (
Default:
0 Exact
 OR next smallest
.
Is a problem when searching for text cause “London” < “Madrid”
) (
Result: 
20 
was
 in row 2 of the 2
nd
 column.
)
3. 


3.     We can combine them into one formula:

ans:	 =INDEX(B1:B3,MATCH("jo",A1:A3,0)) (0 indicates exact match.)

so this is (almost – see below) the equivalent of the VLookup above


Better Method: which uses the whole table reference (as does VLOOKUP).
 (
2
 indicates the column number
 that 
INDEX
 looks in
.
 
ie
 2
nd
 row 
2
nd
 column.
)
=INDEX(A1:B3,MATCH("jo",A1:A3),2)





 (
Prelim: INDEX can use two 
indices:Try
 this:
=
INDEX(
A1:B3,
2
,
2
) means find the element of A2:B3 in the 
2
nd
 row and 
2
nd
 column. 
ie
 20.
)




If the columns are swapped as shown below ie =INDEX(A1:B3,MATCH("jo",B1:B3),1) then Index-Match can work “backwards” (which VLOOKUP can’t!). 





 (
ie
 2
nd
 row 
1
st
 column.
)




[bookmark: Median]So VLOOKUP effectively looks backwards.
New Excel Functions

XMATCH

The MATCH function defaults to exact match or the next smallest item.
The XMATCH function defaults to exact match

The MATCH function uses 1 for the next smallest.
The XMATCH function uses -1 for the next smallest.

The MATCH function uses -1 for the next largest.
The XMATCH function uses 1 for the next largest.

Both the MATCH and the XMATCH functions use 0 for exact match.

XMATCH has a bug when searching for eg “violet” in a list which contains “Violet”. It shouldn’t find it but does.



https://www.youtube.com/watch?v=EPALV2fTo1w




Median








 (
The middle value when arranged in ascending order. Sort them to show that 2.2 is then the middle value.
)




Mode is the most frequent.

Average or mean











Abs ignores sign








Indirect




 (
Returns the value that is in c2.
)
[bookmark: IsError] 
IsError

Returns the logical value TRUE if value refers to any error value, such as #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, or #NULL!; otherwise, it returns FALSE









IFError










Exercise

Use IsError to cover up a VLookup when the lookup value is not found


ans:
=IF(ISERROR(VLOOKUP(E3,$B$3:$C$11,2,FALSE)),"",VLOOKUP(E3,$B$3:$C$11,2,FALSE))


[bookmark: Count] (
Help
To get Help highlight and press F1 or click the 
f
x
.
Commas in formulas mean placeholder for omitted arguments.
)
Count

Count counts the number of numbers.






 (
There are 3 numbers (and one text value which is not counted.)
)



See also CountBlanks, CountA (Counts non-blanks), 

CountIf
 (
Note the inverted commas.
)





 (
There are 3 numbers greater than 5.
)




Countifs

CountIfS is the same as CountIf but it can operate across multiple ranges.

 (
Remember the quote marks for the criterion!
) (
Note that 
CountI
f
S
 works across the column in this case 
ie
 ed must 
also 
have 10 to be counted ie ed 
AND
 10.
There is one
 “ed”
 and 10
on the same row.
)

 (
eg 
=
COUNTIFS(
B2:B5,"=ed",C2:C5,"=
12
")
 
would produce 0.
)




(See Help on Microsoft CountIfs for further examples)


[bookmark: SumIf]
SumIf
 (
Remember the quote marks for the 
criterion!
)




 (
Only numbers bigger than 5 are summed.
)




 (
Remember that the range to be summed comes last.
)More complex:






 (
Only ed’s numbers 
from range A1:A4 
(6 & 9) 
are summed.
)





SumIfs 	See MS Help.
Adds the cells in a range (range: Two or more cells on a sheet. The cells in a range can be adjacent or nonadjacent.) that meet multiple criteria. For example, if you want to sum the numbers in the range A1:A20 only if the corresponding numbers in B1:B20 are greater than zero (0) and the corresponding numbers in C1:C20 are less than 10, you can use the following formula:
=SUMIFS(A1:A6, B1:B6, ">0", C1:C6, "<10")



 (
ie
 
S
um numbers in column A which have a positive number in column B 
AND
 a number <10 in Column C.
ie
2
4
2
1
6
1
3
)







 (
https://support.office.com/en-ie/article/sumifs-function-c9e748f5-7ea7-455d-9406-611cebce642b
)


Concatenate		&




	
“Concatenate” does the same job as the ampersand(&).
[bookmark: Date]
Date and Time Functions
· DATE function Returns the sequential serial number that represents a particular date.
· DATEDIF function Calculates the number of days, months, or years from one date to another date.
· DATEVALUE function Converts a date in a cell that uses the Text cell format into a sequential serial number that you can use in date calculations.
· DAY function Returns only the day of the month of a date. The day is given as an integer, ranging from 1 to 31.
· DAYS360 function Calculates the number of days from one date to another date based on a 360-day year (twelve 30-day months), which is used in some accounting calculations. Use this function to help compute payments if your accounting system is based on twelve 30-day months.
· EDATE function Returns the serial number that represents the date that is a specified number of months before or after start_date. Use EDATE to calculate maturity dates or due dates that fall on the same day of the month as the date of issue.
· EOMONTH function Returns the serial number for the last day of the month that is a specified number of months before or after start_date. Use EOMONTH to calculate maturity dates or due dates that fall on the last day of the month.
· HOUR function Returns only the hour of a time value. The hour is given as an integer, ranging from 0 (12:00 A.M.) to 23 (11:00 P.M.).
· MINUTE function Returns only the minute of a time value. The minute is given as an integer, ranging from 0 to 59.
· MONTH function Returns only the month of a date represented by a serial number. The month is given as an integer, ranging from 1 (January) to 12 (December).
· NETWORKDAYS function Returns the number of whole working days from start_date to end_date. Working days exclude weekends and any dates identified in holidays. Use NETWORKDAYS to calculate employee benefits that accrue based on the number of days worked during a specific term.
· NETWORKDAYS.INTL function Returns the number of whole workdays between two dates.
· NOW function Returns the serial number of the current date and time. If the cell format was General before the function was entered, the result changes the cell formatting to Time.
· SECOND function Returns only the second of a time value. The second is given as an integer, ranging from 0 (zero) to 59.
· TIME function Returns the decimal number for a particular time. If the cell format was General before the function was entered, the result changes the cell formatting to Time.
· TIMEVALUE function Returns the decimal number of a particular time represented by a text string. The decimal number is a value ranging from 0 (zero) to 0.99999999, representing the times from 0:00:00 (12:00:00 A.M.) to 23:59:59 (11:59:59 P.M.).
· TODAY function Returns the serial number of the current date. If the cell format was General before the function was entered, the result changes the cell formatting to Date.
· WEEKDAY function Returns the day of the week corresponding to a date. The day is given as an integer, ranging from 1 (Sunday) to 7 (Saturday), by default.
· WEEKNUM function Returns a number that indicates where the week falls within a year. The week is given as an integer.
· WORKDAY function Returns a number that represents a date that is a specified number of working days before or after start_date. Working days exclude weekends and any dates identified as holidays. Use WORKDAY to exclude weekends or holidays when you calculate invoice due dates, expected delivery times, or the number of days worked.
· WORKDAY.INTL function Returns the serial number of the date before or after a specified number of workdays with custom weekend parameters.
· YEAR function Returns the year corresponding to a date. The year is returned as an integer, ranging from 1900-9999.
· YEARFRAC function Calculates the fraction of the year represented by the number of whole days from start_date to end_date. Use YEARFRAC to identify the proportion of a whole year's benefits or obligations to assign to a specific term



Logical functions
· AND function Returns TRUE if all of its arguments are TRUE
· FALSE function Returns the logical value FALSE
· IF function Specifies a logical test to perform
· IFERROR function Returns a value that you specify if a formula evaluates to an error
· NOT function Reverses the logic of its argument
· OR function Returns TRUE if any argument is TRUE
· TRUE function Returns the logical value TRUE

eg WeekDay
[bookmark: Round]
Round

Rounds a number to a specified number of digits. 





See Roundup, Ceiling, Floor etc

IsText

Returns the logical value TRUE if value refers to text; otherwise, it returns FALSE. 









IsNumber


[bookmark: Mid]
Mid

Returns a specific number of characters from a text string, starting at the position that you specify, based on the number of characters that you specify.







Right






Left




Len



Find




Exercise

Extract the First Name and Surname from a fullname eg Jack Robinson. It must work for any name eg Thenga McKenna. Hint: Find the position of the space first.
[bookmark: Outlining]
Outlining

· Make this table.









 (
Insert the formula
= C4 + C6 to find the grand total here.
)




To Outline Automatically

· With the cursor in the above list…














 (
Click these to collapse to the total for the New York etc.
)














Note that automatic outlining will work so long as we have a formula which is doing the totalling.  

 (
Ungroup, Clear Outline.
)Ungroup them. To Ungroup we need to …



To Outline the Rows Manually

 (
First select the rows that we wish to group 
)












 (
… from the Data tab, Data Tools 
group ,
 choose Group and then Group.
)













 (
Make sure that Rows is checked and then click OK.
)


















Clear Outline from The Ungroup Ribbon item as before.

To Outline the Columns Manually


 (
First select the two columns.
)

 (
… from the Data tab, Data Tools 
group ,
 choose Group and then Group.
)











 (
Choose Columns and click OK.
)







 (
We can click these to see the effect.
)













[bookmark: TrueandFalse]True and False















Or

 (
Type these True False values into columns A and B.
Type in this formula and drag down.
)











We have produced a Truth Table for the OR.

And

Replace the OR formulas above with AND ie =AND(A1,B1) etc and produce the truth table.






Not







· Exercise:  Use on If and an Or to get a NOR (not Or)
[bookmark: Macros]
Macros on Excel 2007/2010

We must first make sure that the Developer Toolbar is on the menu as follows. 

 (
Click the Office button in 2007
) (
In 2010 click File.
)	or…









 (
Choose 
Excel Options.
) (
Options.
)
							or..
· For 2007:


 (
Check Show Developer tab in Ribbon.
)




· For 2010, choose Customize Ribbon and then check the Developer check box and click OK.
[bookmark: Record]
To Record a Macro 		For  Excel 2070 or 2010:






 (
Choose This Workbook.
Choose Ctrl-z to run the macro then click OK.
)






 (
For the moment don’t click anywhere else in the spreadsheet. 
ie
 don’t change the selection else the recorder will record this as well!
)
· Choose Bold Italics etc.

 (
Stop Recording.
)


· Now highlight some text and press Ctrl-z. The text will be formatted Bold Italic or whatever you recorded.
[bookmark: VBA]
To Write Some VBA
· Choose the Developer tab.

 (
Click on the Insert button. (Don't confuse this with Insert on the menu.)
)








 (
Click on the Command Button 
button
.
 
(
Not the Form Controls button.
)
)





 (
Draw a button on the sheet and double-click on it to write some code etc.
)




We can now write our VB code

 (
Click the Visual Basic tab.
)


 (
Write this code.
)






 (
Click the Run button.
)




 (
3 is placed in 
Cell(
1,1).
)


Further: Read Excel VBA in Easy Steps by Ed Robinson!
http://www.amazon.co.uk/Excel-VBA-Easy-Steps-Robinson/dp/1840782714


[bookmark: Math]
Math in Excel

Multiplication/Division takes precedence over Addition/Subtraction.

· Try these:

= 2 * 3 + 4		 -> 10
= 2 + 3 * 4		 -> 14
= 4 / 2 + 3 		 ->  5
= 4 / 2 -  3 		 -> -1

Brackets take precedence over everything. ie Do them first.
(Strictly speaking brackets should be called parentheses.)

=  2 * (3 + 4)		 -> 14
= (2 * 3) + 4		 -> 10       (Brackets makes no difference in this case)
=  4 / (1 + 3)		 ->   1
=  2 * (3 + 4)		 -> 14

Raising to a power:

 eg  23  is written in Excel as  =2^3 which of course gives 8. (Shift-6 will give you the caret.)
Exponentiation as it is called takes precedence over * and /.
eg in Excel (and in mathematics):         = 4 * 2^3   will give  32.
 (
Beware of dividing lines
: 
It is very much overlooked that 
in math
 
a 
long 
dividing line has the same effect as a bracket
.
eg
      
in Math
 we have    
 = 1
So
 the (long) dividing line has the effect of brackets ie the above is equivalent to:
= 1
But 
in Excel we don’t have a long dividing line
. 
So
 if we need to put this into Excel we must use a bracket to emulate the effect of the long dividing line ie 
=4
/(
2+2)
     (If you try it without the brackets, what will you get?)
So to cut a long storey 
short :
 If you were asked to enter 
 into Excel
 you would enter 
=4
/(
2+2)
 to give the correct answer of 1.
(The other way of doing it would be to Enter 
=
 4/
2
/2. This means Divide the 4 by the first AND THEN divided this result by the second 2.)
(The same problem as above exists when using a 
hand held
 calculator. - and as someone would say - "no
 a lot of
 people know that" 
esp
  A
-level math students.)
)=2^


[bookmark: percent]
Percentages

1. To Convert a Decimal into a Percentage multiply by 100.

eg .50 as a percentage is 50%. 

In Excel: = .50 * 100 -> 50.

(In Math to multiply by 100 we of course move the decimal place 2 places to the right 
so .50 -> 50.)

· Try these: Convert to Percentage

.23	->      ……
.40	->
.4  	->
.05	->
.12	->

· In Excel we can achieve the same effect by formatting as a percentage. (See previous notes on this). Try the above by formatting the fraction as a percentage.


 
2. To Convert a Percentage into a Decimal divide by 100.

· Try the above in reverse.
 (
Note that the contents of the cell can still be regarded as the decimal.
eg
 the .23 formatted as a decimal will be 
23%
 
but it is still regarded by Excel as .23
.
It only PRESENTED TO YOU as a percentage.
)






3. To Find the Percentage of a Number

eg Find 50% of 200.

In Math the formula is 



 so the answer should be 100.

So the rule is: Divide the percentage by 100 (ie convert it to a decimal) and then multiply.

· Try these. Find

20% of 500  = …..
10% of480   =
15% of 200  =
12% of 240  =
 6% of 48     =

4 .To find one number as a Percentage of another.

eg What pecentage is 20 of 40?

Rule: Divide the first number by the second and multiply by 100


   -> 50 ie 50%

In Excel: = 20/40 * 100.

BUT in Excel be could also do = 20/40 and the FORMAT the result as a percentage.
Note that the CONTENTS of the cell will be REGARDED as .5 even though it APPEARS as a percentage.



· Try these. Find

20 	as a percentage of 50. 
50 	as a percentage of 200. 
10 	as a percentage of 400. 
  5 	as a percentage of 40. 
 (
Find the percentage increase.
eg
 200 is increased to 240. What is the % increase?
eg
 200 is decreased to 180. What is the % decrease?
)12.5 	as a percentage of 125. 


5. To Increase by a Percentage: In 2 steps first.

eg Increase 200 by 20%

6. To Increase by a Percentage "in one go":

eg Increase 200 by 20%


7. Repeat the above two for a DECREASE.

Difficult: 7. To Find the Original after it has been increased by a Percentage

eg 240 is the result of a 20% increase. What was the original amount?


8. As above but DECREASED,

eg 80 is the result of a 10% decrease. What was the original amount?


9. Very difficult To find the overall % inc after increasing by a percentage TWICE.

200 is increased by 10% and then increased by 20%. What is the overall % incrrease?

Percentages in Excel.

Firstly note that when we enter a fraction , behind the scenes it is a decimal.

eg type 10%

 (
This is true whether we originally 
formatted
 .1 as a decimal or we just 
typed
 10%.
)

     If we toggle Ctrl-grave we can see that it is really .1.



There are two ways of looking at % calculations:

The Excel way and the Math way.

eg what % is 20 of 200 		 (ans 10%)

First:



Now we can proceed in 2 ways:

1. The Math way. Multiply by 100



Note that the answer is 10 and not .1. (This will be important if we use this 10 in future calculations)

2. The Excel way Format as a %

 (
It is important to realize that the result is .1 and not 10. answer is 10 and not .1. (This will be important when using this in future calculations.
)
[bookmark: TextToCol]
To Allocate a Number Set to Different Cells			Text To Columns

 ie Split a group of numbers in one cell to many cells

eg if these numbers are in ONE cell. (Separated by spaces)

 (
Data
, 
Text to Columns.
)







 (
Choose Delimited and then the space for the delimiter (and Next).
)

 (
Choose Finish
)

result:


[bookmark: FV]
Future Value, Present Value,  NPV and IRR (Internal Rate Of Return)

Simple Interest

Find the interest on 100 @ 10% pa for 1 year.



Find the total amount after 1 year



What is the formula



Compound interest

Lets say that the £110 is invested for one more year at the same interest rate.

How much will you have at the end of the 2nd year?

Start again

100 is invested at 10% for 2 years. How much will you have at the end of the 2 years.

What is the quick formula?






The amount that you will have at the end of the 2 years is also called the 
Future Value

eg the above question would read “Find  the FV of 100 @ 10% pa for 2 years “

We can use the Excel FV function although it is a bit tricky.



Just to confuse things this will also give a negative amount:

so we need to either put a minus in front   =-FV(10%,2,0,100) 

or use the ABS formula.       =ABS(FV(10%,2,0,100))

Present Value

Present Value Is Future Value (or Compound Interest) in reverse.

eg the FV of 100 at 10% pa in 2 yrs time is 121 means that the

PV of 121 in 2 years’ time is 100. (Note the slightly strange way that this is expressed.)

We know the formulas for our FV is

The formula for PV is this formula “backwards” ie



Ex:
1.  Find the PV of 200 in 2 yrs time.




2.  Find the PV of 400 in 3 yrs time.




3.  Find the PV of 200 in 2 yrs time and 400 in 3 yrs time.



This total is called the Net Present Value (NPV)

NPV=



	
	
	

	
	
	

	
	
	

	 (
The total is the NPV.
)
	
	

	
	
	

	
	
	


We can use Excel’s NPV function to calculate this directly.
=NPV(C1,B2,B3,B4) but we need to place a 0 in cell B1 for year 1 since Excel’s NPV assumes annual increments.


The IRR (internal rate of return) is the interest rate for which the NPV = 0.

=IRR(B1:B4) eg for -500 in cell B1(initial investment)   ->   7.1%
RANK   						addressesExpt.xlsm

	7
	
	RANK.EQ
	
	RANK.AVG
	 

	4
	Rank of the 4 in the list ->
	3
	=RANK.EQ(4,$A$1:$A$5,1)
	3.5
	=RANK.AVG(4,$A$1:$A$5,1)

	4
	Rank of the 7 in the list-> 
	5
	=RANK.EQ(7,$A$1:$A$5,1)
	5
	=RANK.AVG(7,$A$1:$A$5,1)

	1
	
	
	
	
	
	
	

	2
	
	
	(In all cases there is nothing with rank of 4)
	
	

	
	
	
	
	
	
	
	

	
	 (
RANK.EQ() = the old 
RANK(
)
 in 
prev
 versions
)
	
	
	
	
	




Explicit Intersection











Or name row 5 as IBM and column S as PX_FIRST and then use the formula



[bookmark: ddown]
Drop-Down List





































[bookmark: ChartsCont]
Charts cont’d

Make this chart of the number of bears seen at the National Park.
 (
(The data can be copied from here.)
)

ie Select data, Inset, Column chart. 

	
	jan
	feb
	mar
	apr
	may
	total

	bears
	32
	45
	23
	34
	22
	156



 (
The legend is 
automatically 
taken from the 
series
.
) (
It is 
quite obvious
 in this case that the Horizontal axis is the months.
) (
The number of bears here is called a 
Series
. A series is plotted on the vertical axis.
)



Right-click on the chart and choose Select data, The Select Data Source dialog box appears:


 (
Series
: vertical axis.
)














 (
You may wish to copy and paste our data as the transpose.
(Paste Special, Transpose) and make the chart. The same chart should result.
)










Add the series for the lions and tigers as shown below: (The data can be copied from here.)

	
	jan
	feb
	mar
	apr
	may
	total

	bears
	32
	45
	23
	34
	22
	156

	lions
	23
	54
	65
	23
	54
	219

	tigers
	38
	54
	76
	21
	45
	234

	total
	93
	153
	164
	78
	121
	609



Make the chart as before. 




The number of animals by month.










Right-click on the chart and choose Select data, The Select Data Source dialog box appears:


















 (
Click to switch the axes.
) (
Note the extra series we now have.
)
















 (
   
The Series are now the months.
)









The number of months
per animal.








To manually edit the series etc

 (
Click Edit
)


















 (
The series 
name
 is cosmetic (in this case “
jan
”).
)












 (
Edit this to include more values in the series for example.
)


Each series could be a different chart type. eg line or column:

To change the chart type

For the exercise we will change the Feb series to a Line type.
 (
Select the Feb series
 and right-click on it.
)


 (
Choose Change Series Chart Type.
) (
Note carefully how the corresponding data is also selected.
)








 (
Choose Line
 and OK.
)








 (
(For what 
it’s
 worth) the 2
nd
 Series (
jan
) has been plotted as a Line.
)

The change the Chart type for all series

 (
Right-click on either the Plot area (the 
inside
 box) or the Chart Area 
(
the container
) and choose Change Chart Type.
)

















 (
Choose Stacked Column and OK.
)






 (
ALL the series have been converted
 to stacked
.
)
Pies & Donuts

Can only do one Pie series at a time. (So use stacked Pies for more than one series?)
https://wmfexcel.com/2017/02/25/want-some-pies/








To change individual sectors




 (
Data.
)




Can have concentric Donut:






Plot Area and Chart Area

 (
Plot Area.
) (
Chart Area.
)


				To format horizontal axis select axis do this:








We have produced an embedded chart.

    Chart sheet:
 (
We may also place a chart on separate 
Chart Sheet
 as follows: Select the chart and from the menu choose the Design tab and then Move Chart Location. Choose a new sheet:
)


 (
Only a (separate) 
chartsheet
 as shown here can have 
events
:
ie
 the chart as produced above 
cannot
 (Try double-clicking on the above chart!) - and to call these events we need to place an old-fashioned Forms button on the chart at that!
)














To Plot a Line

X-Y scatter graph! 














 (
Remove the other (x) series and set the x-values to column A.
)




































Data Labels


To add data labels we can right-click on the chart…

 (
… and choose Add Data Labels.
)





 (
To modify the label's formatting etc right-click on a label and choose Format Data Series and then use
 the dialog box below to modify
.
)
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